• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: GuruPlug Server Plus and Kernel 2.6.34  (Read 5471 times)
gerbi
Newbie
*

Karma: 0
Posts: 3


View Profile
« on: May 20, 2010, 10:54:37 AM »

Hello,

I got my new GuruPlug Server Plus and dove right in Wink
As I want to record DVB-T Video, I followed this guide http://www.openplug.org/plugwiki/index.php/DVB-T and compiled a custom kernel 2.6.34.
To be more precise, I followed this guide http://plugcomputer.org/plugwiki/index.php/Compiling_Linux_Kernel_for_the_Plug_Computer#Booting_the_kernel to actually build the kernel and so far so good. I flashed the new kernel to nand and rebooted the Plug.

It starts, but displays the message:
Code:
NAND read: device 0 offset 0x100000, size 0x400000
 4194304 bytes read: OK
## Booting kernel from Legacy Image at 06400000 ...
   Image Name:   Linux-2.6.34
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    2307428 Bytes =  2.2 MB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK
OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.

Error: unrecognized/unsupported machine ID (r1 = 0x00000a29).

Available machine support:

ID (hex)        NAME
00000690        Marvell DB-88F6281-BP Development Board
00000691        Marvell RD-88F6192-NAS Development Board
00000692        Marvell RD-88F6281 Reference Board
0000078c        Marvell 88F6281 GTW GE Board
00000831        Marvell SheevaPlug Reference Board
0000085b        QNAP TS-119/TS-219
000009c6        QNAP TS-41x
00000939        Marvell OpenRD Client Board
00000915        Marvell OpenRD Base Board
00000899        LaCie Network Space v2

Please check your kernel config and/or bootloader.

As mentioned in the guide, I added
Code:
setenv arcNumber 2097
setenv mainlineLinux yes
to my uBoot Boot arguments, but that didn't help.
I tried to change the arcNumber, but without any success.

My current boot config looks like this:
Code:
Marvell>> printenv
bootdelay=3
baudrate=115200
x_bootcmd_ethernet=ping 192.168.2.1
x_bootcmd_usb=usb start
x_bootcmd_kernel=nand read.e 0x6400000 0x100000 0x400000
x_bootargs=console ttyS0,115200
x_bootargs_root=ubi.mtd=2 root=ubi0:rootfs rootfstype=ubifs
ethact=egiga0
ethaddr=00:50:43:XX:XX:XX
eth1addr=00:50:43:XX:XX:XX
bootcmd=setenv ethact egiga0; ${x_bootcmd_ethernet}; setenv ethact egiga1; ${x_bootcmd_ethernet}; ${x_bootcmd_usb}; ${x_bootcmd_kernel}; setenv bootargs ${x_bootargs} ${x_bootargs_root}; bootm 0x6400000;
stdin=serial
stdout=serial
stderr=serial
arcNumber=1932
mainlineLinux=yes

Any ideas / suggestions what might be wrong? I would really like that DVB-T support...
Logged

gerbi
Newbie
*

Karma: 0
Posts: 3


View Profile
« Reply #1 on: May 21, 2010, 10:07:00 AM »

hi there,

I played around a bit more and reflashed the kernel with the one found here http://plugcomputer.org/index.php/us/resources/downloads?func=select&id=17 and the plug is booting again.

I couldn't get this kernel or my self compiled kernel to successfully boot from a tftp server.
Any ideas why that might be?
The stock kernel just stops after "uncompressing image" and my self compiled kernel still says it can't detect the device. It seems, as if setenv arcNumber 2097 doesn't work / isn't recognized.

Logged

vthokie
Newbie
*

Karma: 0
Posts: 8


View Profile
« Reply #2 on: May 21, 2010, 10:17:40 AM »

I was finally able to get 2.6.34 to boot by upgrading the uboot to the latest version on this site.  Once you upgrade though, you'll also have to flash the kernel to the latest version on the site since the factory default one stops working after upgrading the uboot.  You may also want to upgrade the root file system as well to make everything happy.  Once I did all that, my custom 2.6.34 kernel finally booted.
Logged

b382f29
Newbie
*

Karma: 0
Posts: 4


View Profile
« Reply #3 on: May 21, 2010, 10:45:02 AM »

Hi,

I still can't get the vanilla 2.6.34 kernel to boot.
It would be great if you could describe exactly how you got it to boot via tftp, and what versions of uBoot you are using, (I'm using U-Boot 2010.03-01161-gd91b0a9 (Apr 22 2010 - 03:24:41) from http://www.plugcomputer.org/index.php/us/resources/downloads?func=fileinfo&id=71 but I still get the error about the unrecognized/unsupported machine ID.

Logged

gerbi
Newbie
*

Karma: 0
Posts: 3


View Profile
« Reply #4 on: May 21, 2010, 11:28:52 AM »

Hi,

I think my have found the problem...

As the new kernel posted on plugcomputer.org works, I thought about simply compiling that one with the DVB-T settings enabled and behold that works.
I looked through the config file and found, that it has slightly different settings, namely that they enabled "Marvell GuruPlug Reference Board" under "Marvell Kirkwood Implementations" when you do a "make ARCH=arm menuconfig". I had not enabled this on my 2.6.34 kernel and that might have been the problem.

To be clear, at the moment I have Kernel 2.6.33.2 with the latest uBoot (010.03-01161-gd91b0a9) running and am happy, as I don't really see an added value in Kernel 2.6.34. Or am I missing something?

I didn't have to specify any boot arguments for uBoot by the way.
Logged

b382f29
Newbie
*

Karma: 0
Posts: 4


View Profile
« Reply #5 on: May 21, 2010, 11:48:38 AM »

Ah, thanks, I see, the Guruplug support is not yet in the released kernel but it is in the "vanilla" git patch from kernel.org

http://www.kernel.org/diff/diffview.cgi?file=%2Fpub%2Flinux%2Fkernel%2F%2Fv2.6%2Fsnapshots%2Fpatch-2.6.34-git6.bz2;z=285

So this might hopefully be in the next kernel release.
Logged

vthokie
Newbie
*

Karma: 0
Posts: 8


View Profile
« Reply #6 on: May 21, 2010, 04:11:31 PM »

Yeah, you definitely want to apply the Marvell patch set to the vanilla kernel.  It patched pretty easily against 2.6.34 using the directions in the wiki.

I loaded my kernel from a USB stick.

Also, I have the April version of uboot running on mine.
Logged

Pages: [1]
Print
Jump to: