• Home
  • Help
  • Search
  • Login
  • Register
Pages: 1 [2]
Author Topic: Trying to install 2.6.30-rc2  (Read 10556 times)
jdonth
Jr. Member
**

Karma: 0
Posts: 75

Azle, Texas


View Profile
« Reply #15 on: April 27, 2009, 12:42:21 PM »


No - it is still locked at "booting the kernel".

Reading data from 0x4ff800 -- 100% complete.
 4194304 bytes read: OK
## Booting image at 00800000 ...
   Image Name:   Linux-2.6.30-rc2
   Created:      2009-04-24   7:07:31 UTC
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    2151820 Bytes =  2.1 MB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
OK

Starting kernel ...

Uncompressing Linux...
............................... done, booting the kernel.

I changed the following u-boot settings when I switched from nfs to nand:

setenv bootargs 'console=ttyS0,115200 mtdparts=orion_flash:0x400000@0x100000(uImage)ro,0x1fb00000@0x500000(rootfs) root=/dev/mtdblock2'
setenv bootcmd 'nand read.e 0x800000 0x100000 0x400000; bootm 0x800000'
saveenv
reset


Anyone see anything wrong?

Logged

...I've always depended on the kindness of strangers

cbxbiker61
Global Moderator
Sr. Member
*****

Karma: 38
Posts: 497


View Profile
« Reply #16 on: April 27, 2009, 12:49:34 PM »

Like kilowatt mentioned.

setenv mainlineLinux yes
setenv arcNumber 2097

If you didn't set those it won't boot.
Logged

jdonth
Jr. Member
**

Karma: 0
Posts: 75

Azle, Texas


View Profile
« Reply #17 on: April 27, 2009, 12:50:03 PM »

THANKS!

I made the suggested changes to u-boot:

setenv mainlineLinux yes
setenv arcNumber 2097
setenv bootargs 'console=ttyS0,115200 mtdparts=orion_flash:0x100000@0x000000(u-boot)ro,0x400000@0x100000(uImage)ro,0x1fb00000@0x500000(rootfs) root=/dev/mtdblock2'
setenv bootcmd 'nand read.e 0x800000 0x100000 0x400000; bootm 0x800000'


It loaded the kernel and init'd until:

lib80211: common routines for IEEE802.11 drivers
rtc-mv rtc-mv: setting system clock to 2087-07-17 13:06:23 UTC (3709285583)
List of all partitions:
1f00            1024 mtdblock0 (driver?)
1f01            4096 mtdblock1 (driver?)
1f02          519168 mtdblock2 (driver?)
No filesystem could mount root, tried:  ext2 cramfs vfat msdos
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,2)
[<c002a9b8>] (unwind_backtrace+0x0/0xe0) from [<c00362cc>] (panic+0x64/0x128)
[<c00362cc>] (panic+0x64/0x128) from [<c0008d60>] (mount_block_root+0x1d4/0x214)
[<c0008d60>] (mount_block_root+0x1d4/0x214) from [<c0008fc4>] (prepare_namespace+0x128/0x180)
[<c0008fc4>] (prepare_namespace+0x128/0x180) from [<c000871c>] (kernel_init+0xc0/0xec)
[<c000871c>] (kernel_init+0xc0/0xec) from [<c0039240>] (do_exit+0x0/0x6e0)

Logged

...I've always depended on the kindness of strangers

cbxbiker61
Global Moderator
Sr. Member
*****

Karma: 38
Posts: 497


View Profile
« Reply #18 on: April 27, 2009, 12:58:36 PM »

Add rootfstype=jffs2 to your boot args and you should be golden.  Of course I'm assuming you rewrote your rootfs when you changed your partition locations.
Logged

kilowatt
Global Moderator
Full Member
*****

Karma: 3
Posts: 106


View Profile
« Reply #19 on: April 27, 2009, 01:00:06 PM »

Now it looks like you don't have a valid files system in the rootfs partition.  since you moved the partition you need to write the jffs2 file system to the new partition.

You should be able to boot from NFS using the new kernel that is now in flash.  Then write the file system.

flash_eraseall -j /dev/mtd2
nandwrite -m /dev/mtd2 YourFileSystem.jffs2
« Last Edit: April 27, 2009, 01:01:57 PM by kilowatt » Logged

jdonth
Jr. Member
**

Karma: 0
Posts: 75

Azle, Texas


View Profile
« Reply #20 on: April 27, 2009, 01:10:37 PM »

Some confusion on the nandwrite command.

nandwrite -p /dev/mtd2 /ubuntu-9.0.5.Release.jffs2
nandwrite -m /dev/mtd2 /ubuntu-9.0.5.Release.jffs2
nandwrite -pm /dev/mtd2 /ubuntu-9.0.5.Release.jffs2
nandwrite /dev/mtd2 /ubuntu-9.0.5.Release.jffs2

Any thoughts on which command to use for the rootfs?
Any explanation on what the different options do?

I really appreciate all the help!
Logged

...I've always depended on the kindness of strangers

jdonth
Jr. Member
**

Karma: 0
Posts: 75

Azle, Texas


View Profile
« Reply #21 on: April 27, 2009, 01:14:43 PM »


No go!

Rewrote the jffs2 image to mdt2 but on reboot I get:

List of all partitions:
1f00            1024 mtdblock0 (driver?)
1f01            4096 mtdblock1 (driver?)
1f02          519168 mtdblock2 (driver?)
No filesystem could mount root, tried:  ext2 cramfs vfat msdos
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,2)
[<c002a9b8>] (unwind_backtrace+0x0/0xe0) from [<c00362cc>] (panic+0x64/0x128)
[<c00362cc>] (panic+0x64/0x128) from [<c0008d60>] (mount_block_root+0x1d4/0x214)
[<c0008d60>] (mount_block_root+0x1d4/0x214) from [<c0008fc4>] (prepare_namespace+0x128/0x180)
[<c0008fc4>] (prepare_namespace+0x128/0x180) from [<c000871c>] (kernel_init+0xc0/0xec)
[<c000871c>] (kernel_init+0xc0/0xec) from [<c0039240>] (do_exit+0x0/0x6e0)


I don't see it looking for a jffs2 filesystem.

Logged

...I've always depended on the kindness of strangers

cbxbiker61
Global Moderator
Sr. Member
*****

Karma: 38
Posts: 497


View Profile
« Reply #22 on: April 27, 2009, 01:17:58 PM »

"nandwrite /dev/mtd2 /ubuntu-9.0.5.Release.jffs2" should work just fine it's straight out of Marvell's doc. "-p" is for the kernel image not for the filesystem.

Again, you probably also need to put "rootfstype=jffs2" in your bootargs.
Logged

jdonth
Jr. Member
**

Karma: 0
Posts: 75

Azle, Texas


View Profile
« Reply #23 on: April 27, 2009, 01:24:10 PM »


BINGO!

It booted and I was able to ssh into the 2.6.30-rc2 kernel.

Got a bunch of init errors but will take a peek at dmesg before getting too concerned.

Thank you to all three of you guys!

~Joe Donth
Logged

...I've always depended on the kindness of strangers

kilowatt
Global Moderator
Full Member
*****

Karma: 3
Posts: 106


View Profile
« Reply #24 on: April 27, 2009, 04:15:02 PM »

Quote
nandwrite -p /dev/mtd2 /ubuntu-9.0.5.Release.jffs2
nandwrite -m /dev/mtd2 /ubuntu-9.0.5.Release.jffs2
nandwrite -pm /dev/mtd2 /ubuntu-9.0.5.Release.jffs2
nandwrite /dev/mtd2 /ubuntu-9.0.5.Release.jffs2

nandwrite --help explains the options
-p pad to page size.  The JFFS2 image is already padded. but the kernel is not.  Use it for kernel writes.
-m mark blocks bad if the write fails.  Seems appropriate to use for both kernel and file system.
Logged

Pages: 1 [2]
Print
Jump to: