• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Configuration of GuruPlug Plus  (Read 6235 times)
popon
Newbie
*

Karma: 3
Posts: 24


View Profile
« on: May 17, 2010, 11:00:01 PM »

I struggle with my GuruPlug Plus, and get somethings:
1)  Power on the Guruplug, wireless AP with IP 192.168.1.1 will be set up with no security. You can use ssh to login into
     the GuruPlug Plus.
2)  By configuring /etc/network/interfaces, one can modify eth0 ,or eth1 by a static IP,  connect eth1 ( eth0) to the
     router of the network, one can use ssh to login into GuruPlug  with IP of eth1(eth0). In this case, GuruPlug 
    is connected to the internet through the network.
3) Since the no security of wireless AP, I deleted the line "/root/init_setup.sh" in /etc/rc.local, which set up the
    wireless. So, the wireless is disabled.
4)  #cat /etc/debian_version, it shows 5.03. I editied /apt/sources.list as the same as my sheevaplug( I installed
     Debian lenny).   By update and   upgrade, #cat /etc/debian_version becomes 5.0.4. The version of debian
     becomes the same as    that of my   sheevaplug.
5) For serial login to Guruplug, the guidance only shows the case of Federa Core 11. The  serial login is also available
    by windows XP. 

The next of my target  is to modify the wireless AP with WPA2 security.

Logged

ppmt
Full Member
***

Karma: 1
Posts: 129


View Profile
« Reply #1 on: May 18, 2010, 06:56:13 AM »

I used that link to configure and secure my wifi connection

I now use WPA2

http://plugcomputer.org/plugwiki/index.php/Setting_GuruPlug_to_be_a_WiFi_Access_Point
Logged

popon
Newbie
*

Karma: 3
Posts: 24


View Profile
« Reply #2 on: May 18, 2010, 04:57:18 PM »

Thx for your response
I also noticed this html page, but confused by that : where are the files saved the setting values ?

 
Logged

ppmt
Full Member
***

Karma: 1
Posts: 129


View Profile
« Reply #3 on: May 18, 2010, 05:25:17 PM »

I saved them in the script that is /root

it is where the initial wifi is configured...so basically it is run at every reboot
Logged

zibonmm2
Newbie
*

Karma: -3
Posts: 1


View Profile
« Reply #4 on: May 18, 2010, 10:28:13 PM »

Globalscale Technologies has just launch the GuruPlug Server Plus and GuruPlug Server, a compact computer which is powered by Marvell Kirkwood 1.2GHz processor, 512MB RAM, 512MB flash memory, supports Bluetooth, WiFi 802.11b/g, comes with two USB ports, an eSATA port, microSD slot, two Ethernet ports, the U-SNAP I/O, and comes with pre-installed Linux operating system using Kernel version 2.6.32. While the GuruPlug Server comes without .

Jeep Scrambler Parts
Logged

kidgib
Newbie
*

Karma: 0
Posts: 1


View Profile
« Reply #5 on: May 21, 2010, 02:42:19 PM »

Even though I modified /etc/network/interfaces to read:
# Used by ifup(Cool and ifdown(Cool. See the interfaces(5) manpage or
# /usr/share/doc/ifupdown/examples for more information.
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
 address 192.168.1.6
 gateway 192.168.1.254
 netmask 255.255.255.0
 network 192.168.1.0
 broadcast 192.168.1.255

It has no effect.  when I do /etc/init.d/networking restart my plug freezes up.
When I unplug it and reboot I can log back in under 192.168.1.1 (wired!)
and this is my ifconfig:
sheevaplug-debian:/etc/rc3.d# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:50:43:01:83:d0 
          inet addr:192.168.1.232  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::250:43ff:fe01:83d0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1017 errors:0 dropped:0 overruns:0 frame:0
          TX packets:628 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:106906 (104.4 KiB)  TX bytes:81170 (79.2 KiB)
          Interrupt:11

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:480 (480.0 B)  TX bytes:480 (480.0 B)

uap0      Link encap:Ethernet  HWaddr 00:24:23:1f:9d:e5 
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
Logged

popon
Newbie
*

Karma: 3
Posts: 24


View Profile
« Reply #6 on: May 22, 2010, 04:23:08 PM »

In my case, I set /etc/network/interfaces as:
#---- begin-----
auto lo
iface lo inet loopback

iface eth0 inet static
address 192.168.1.6
netmask 255.255.255.0
gateway 192.168.1.2

auto eth0
#---end--------

I connect eth0 to my home network with the router IP 192.168.1.2 So, I set the gateway as the IP
of my router.
You may be try to set "gateway 192.168.1.1".
Logged

preaton
Newbie
*

Karma: 0
Posts: 7


View Profile
« Reply #7 on: May 22, 2010, 08:27:46 PM »

Unfortunately the default ip address for uap0 (the access point is 192.168.1.1) This is the same as my network gateway/dns/dhcp server. So essentially until I disabled uap0 I couldn't access by wired ssh. Disable uap0 by running /root/wlan.sh which is supposed to be there. Wasn't on my plug so had to download it.

I also had some issues with ipv6 on my setup. Fould it easier to use /etc/network/interfaces and stick to ipv4 than fiddle with the ifplugd stuff.

I've now upgraded to Debian Squeeze which seems to be working OK. Still the original kernel.

Wouldn't it be nice if there was some documentation somewhere.   Huh
Logged

popon
Newbie
*

Karma: 3
Posts: 24


View Profile
« Reply #8 on: May 23, 2010, 02:54:27 AM »

You can change the default Wireless AP IP address to other.
This purpose can be achieved by editing,
/etc/udhcpd.conf and /root/init_setup.sh,
change 192.168.1.1 to 192.168.1.xxxx, in which "xxx" is that you want
with the value from "1" to "255".
Logged

Pages: [1]
Print
Jump to: