• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Hardware Abstraction Layer (hal) package breaking in Ubuntu  (Read 10496 times)
Art Botterell

Karma: 0
Posts: 5

View Profile
« on: April 26, 2009, 01:36:52 PM »

Recently-received Plug, upgraded to latest Ubuntu 9.04 release, then installed openjdk, which brought hal with it (for pulseaudio-module-hal, apparently.) 

Now when I boot I get an error "Unable to handle kernel paging request at virtual address 000280d0" followed by a stack dump and backtrace and then:

invoke-rc.d: initscript hal, action "start" failed.
dpkg: error processing hal (--configure): 
 subprocess post-installation script returned error exit status 2"

Same thing happens when I try apt-get install hal... apparently the hal install failed partway, which in turn makes pulseaudio-modules-hal fail.  I'm not sure I really care, although I did have a bit of audio processing in mind down the line.  But I'm curious whether anyone has any insights on this.

Rabeeh Khoury
Full Member

Karma: 5
Posts: 218

View Profile
« Reply #1 on: April 26, 2009, 02:12:47 PM »

Which kernel are you using?
Please send FULL log from U-Boot prints until failure.

Art Botterell

Karma: 0
Posts: 5

View Profile
« Reply #2 on: April 26, 2009, 03:01:23 PM », booting from the SD.

Restarting system.
Reseting !!

         __  __                      _ _
        |  \/  | __ _ _ ____   _____| | |
        | |\/| |/ _` | '__\ \ / / _ \ | |
        | |  | | (_| | |   \ V /  __/ | |
        |_|  |_|\__,_|_|    \_/ \___|_|_|
 _   _     ____              _
| | | |   | __ )  ___   ___ | |_
| | | |___|  _ \ / _ \ / _ \| __|
| |_| |___| |_) | (_) | (_) | |_
 \___/    |____/ \___/ \___/ \__|

U-Boot 1.1.4 (Mar 19 2009 - 16:06:59) Marvell version: 3.4.16

U-Boot code: 00600000 -> 0067FFF0  BSS: -> 006CEE80

Soc: 88F6281 A0 (DDR2)
CPU running @ 1200Mhz L2 running @ 400Mhz
SysClock = 400Mhz , TClock = 200Mhz

DRAM CAS Latency = 5 tRP = 5 tRAS = 18 tRCD=6
DRAM CS[0] base 0x00000000   size 256MB
DRAM CS[1] base 0x10000000   size 256MB
DRAM Total size 512MB  16bit width
Flash:  0 kB
Addresses 8M - 0M are saved for the U-Boot usage.
Mem malloc Initialization (8M - 7M): Done

CPU : Marvell Feroceon (Rev 1)

Streaming disabled
Write allocate disabled

USB 0: host mode
PEX 0: interface detected no Link.
Net:   egiga0 [PRIME], egiga1
Hit any key to stop autoboot:  0

NAND read: device 0 offset 0x100000, size 0x400000

Reading data from 0x4ff800 -- 100% complete.
 4194304 bytes read: OK
## Booting image at 00800000 ...
   Image Name:   Linux-
   Created:      2009-03-19   9:18:16 UTC
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    2106696 Bytes =  2 MB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.
Linux version (dhaval@devbox) (gcc version 4.2.1) #1 Thu Mar 19 14:46:22 IST 2009
CPU: ARM926EJ-S [56251311] revision 1 (ARMv5TE), cr=00053177
Machine: Feroceon-KW
Using UBoot passing parameters structure
Memory policy: ECC disabled, Data cache writeback
CPU0: D VIVT write-back cache
CPU0: I cache: 16384 bytes, associativity 4, 32 byte lines, 128 sets
CPU0: D cache: 16384 bytes, associativity 4, 32 byte lines, 128 sets
Built 1 zonelists.  Total pages: 130048
Kernel command line: console=ttyS0,115200=mtdparts=nand_mtd:0x400000@0x100000(uImage),0x1fb00000@0x500000(rootfs) rw root=/dev/mmcblk0p1 rw ip=
PID hash table entries: 2048 (order: 11, 8192 bytes)
Console: colour dummy device 80x30
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 256MB 256MB 0MB 0MB = 512MB total
Memory: 515456KB available (3864K code, 257K data, 104K init)
Mount-cache hash table entries: 512
CPU: Testing write buffer coherency: ok
NET: Registered protocol family 16

CPU Interface
SDRAM_CS0 ....base 00000000, size 256MB
SDRAM_CS1 ....base 10000000, size 256MB
SDRAM_CS2 ....disable
SDRAM_CS3 ....disable
PEX0_MEM ....base e8000000, size 128MB
PEX0_IO ....base f2000000, size   1MB
INTER_REGS ....base f1000000, size   1MB
NFLASH_CS ....base fa000000, size   2MB
SPI_CS ....base f4000000, size  16MB
BOOT_ROM_CS ....no such
DEV_BOOTCS ....no such
CRYPT_ENG ....base f0000000, size   2MB

  Marvell Development Board (LSP Version KW_LSP_4.2.7_patch2)-- SHEEVA PLUG  Soc: 88F6281 A0 LE

 Detected Tclk 200000000 and SysClk 400000000
MV Buttons Device Load
Marvell USB EHCI Host controller #0: c08b8600
PEX0 interface detected no Link.
PCI: bus0: Fast back to back transfers enabled
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
NET: Registered protocol family 2
Time: kw_clocksource clocksource has been installed.
IP route cache hash table entries: 16384 (order: 4, 65536 bytes)
TCP established hash table entries: 65536 (order: 7, 524288 bytes)
TCP bind hash table entries: 65536 (order: 6, 262144 bytes)
TCP: Hash tables configured (established 65536 bind 65536)
TCP reno registered
RTC registered
Use the XOR engines (acceleration) for enhancing the following functions:
  o RAID 5 Xor calculation
  o kernel memcpy
  o kenrel memzero
Number of XOR engines to use: 4
mvCesaInit: sessions=640, queue=64, pSram=f0000000
Warning: TS unit is powered off.
MV Buttons Driver Load
NTFS driver 2.1.28 [Flags: R/O].
JFFS2 version 2.2. (NAND) ‚© 2001-2006 Red Hat, Inc.
io scheduler noop registered
io scheduler anticipatory registered (default)
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing disabled
serial8250.0: ttyS0 at MMIO 0xf1012000 (irq = 33) is a 16550A
serial8250.0: ttyS1 at MMIO 0xf1012100 (irq = 34) is a 16550A
Loading Marvell Ethernet Driver:
  o Cached descriptors in DRAM
  o DRAM SW cache-coherency
  o Single RX Queue support - ETH_DEF_RXQ=0
  o Single TX Queue support - ETH_DEF_TXQ=0
  o TCP segmentation offload enabled
  o Receive checksum offload enabled
  o Transmit checksum offload enabled
  o Network Fast Processing (Routing) supported
  o Driver ERROR statistics enabled
  o Driver INFO statistics enabled
  o Proc tool API enabled
  o Rx descripors: q0=128
  o Tx descripors: q0=532
  o Loading network interface(s):
    o eth0, ifindex = 1, GbE port = 0
    o eth1, ifindex = 2, GbE port = 1

mvFpRuleDb (dfd00000): 16384 entries, 65536 bytes
Intel(R) PRO/1000 Network Driver - version 7.3.20-k2-NAPI
Copyright (c) 1999-2006 Intel Corporation.
e100: Intel(R) PRO/100 Network Driver, 3.5.17-k4-NAPI
e100: Copyright(c) 1999-2006 Intel Corporation

Warning Sata is Powered Off
NFTL driver: nftlcore.c $Revision: 1.98 $, nftlmount.c $Revision: 1.41 $
NAND device: Manufacturer ID: 0xad, Chip ID: 0xdc (Hynix NAND 512MiB 3,3V 8-bit)
Scanning device for bad blocks
Bad eraseblock 431 at 0x035e0000
Bad eraseblock 1030 at 0x080c0000
Bad eraseblock 1031 at 0x080e0000
Bad eraseblock 1032 at 0x08100000
Bad eraseblock 1033 at 0x08120000
Bad eraseblock 1034 at 0x08140000
Bad eraseblock 1035 at 0x08160000
Using static partition definition
Creating 3 MTD partitions on "nand_mtd":
0x00000000-0x00100000 : "u-boot"
0x00100000-0x00300000 : "uImage"
0x00300000-0x20000000 : "root"
ehci_marvell ehci_marvell.70059: Marvell Orion EHCI
ehci_marvell ehci_marvell.70059: new USB bus registered, assigned bus number 1
ehci_marvell ehci_marvell.70059: irq 19, io base 0xf1050100
ehci_marvell ehci_marvell.70059: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
USB Universal Host Controller Interface driver v3.0
usbcore: registered new interface driver usblp
drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
mice: PS/2 mouse device common for all mice
i2c /dev entries driver
Linux telephony interface: v1.00
Marvell Telephony Driver:
mvBoardVoiceAssembleModeGet: TDM not supported(boardId=0x9)
mp_check_config: Error, invalid voice assembley mode
md: linear personality registered for level -1
md: raid0 personality registered for level 0
md: raid1 personality registered for level 1
raid6: int32x1     97 MB/s
raid6: int32x2    114 MB/s
raid6: int32x4    122 MB/s
raid6: int32x8    110 MB/s
raid6: using algorithm int32x4 (122 MB/s)
md: raid6 personality registered for level 6
md: raid5 personality registered for level 5
md: raid4 personality registered for level 4
raid5: measuring checksumming speed
   arm4regs  :  1084.000 MB/sec
   8regs     :   754.800 MB/sec
   32regs    :   899.600 MB/sec
raid5: using function: arm4regs (1084.000 MB/sec)
device-mapper: ioctl: 4.11.0-ioctl (2006-10-12) initialised: dm-devel@redhat.com
dm_crypt using the OCF package.
sdhci: Secure Digital Host Controller Interface driver
sdhci: Copyright(c) Pierre Ossman
mvsdmmc: irq =28 start f1090000
mvsdmmc: no IRQ detect
usbcore: registered new interface driver usbhid
drivers/hid/usbhid/hid-core.c: v2.6:USB HID core driver
Advanced Linux Sound Architecture Driver Version 1.0.14 (Thu May 31 09:03:25 2007 UTC).
mvCLAudioCodecRegGet: Error while reading register!
mvCLAudioCodecInit: Error - Invalid Cirrus Logic chip/rev ID!
Error - Cannot initialize audio decoder.at address =0xff<6>ALSA device list:
  #0: Marvell mv88fx_snd ALSA driver
TCP cubic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
mmc0: host does not support reading read-only switch. assuming write-enable.
mmc0: new high speed SD card at address 2778
mmcblk0: mmc0:2778 SD02G 1921024KiB
 mmcblk0: p1
eth0: link down
eth0: started
IP-Config: Complete:
      device=eth0, addr=, mask=, gw=,
     host=DB88FXX81, domain=, nis-domain=(none),
     bootserver=, rootserver=, rootpath=
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on mmcblk0p1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem).
Freeing init memory: 104K
 * Filesystem type 'fusectl' is not supported. Skipping mount.
 * Setting preliminary keymap...                                         [ OK ]
 * Starting kernel event manager...                                             eth0: link up, full duplex, speed 100 Mbps
                                                                         [ OK ]
 * Loading hardware drivers...                                           [ OK ]
 * Loading kernel modules...                                                     * Loading manual drivers...                                                       [ OK ]
 * Setting kernel variables (/etc/sysctl.conf)...                        [ OK ]
 * Setting kernel variables (/etc/sysctl.d/10-console-messages.conf)...  [ OK ]
 * Setting kernel variables (/etc/sysctl.d/10-network-security.conf)...         error: "net.ipv4.tcp_syncookies" is an unknown key
 * Activating swap...                                                    [ OK ]
FATAL: Could not load /lib/modules/ No such file or directory
FATAL: Could not load /lib/modules/ No such file or directory
 * Starting early crypto disks...                                        [ OK ]
FATAL: Could not load /lib/modules/ No such file or directory
FATAL: Could not load /lib/modules/ No such file or directory
 * Starting remaining crypto disks...                                    [ OK ]
 * Checking file systems...                                                     fsck 1.41.4 (27-Jan-2009)
                                                                         [ OK ]
 * Mounting local filesystems...                                                mount: special device rootfs does not exist
 * Activating swapfile swap...                                           [ OK ]
 * Configuring network interfaces...                                     [ OK ]
 * Setting up console font and keymap...                                 [ OK ]
 * Reloading /etc/samba/smb.conf smbd only
 * Starting system log daemon...                                         [ OK ]
                                                                                * Starting kernel log daemon...                                                           
Ubuntu 9.04 plug0 ttyS0

plug0 login:                                                             [ OK ]
                                                                                * Starting system message bus dbus                                                 [ OK ]
                                                                                * Starting OpenBSD Secure Shell server sshd                                        [ OK ]
                                                                                * Starting Samba daemons                                                           [ OK ]
                                                                                * Starting Hardware abstraction layer hald                                                Unable to handle kernel paging request at virtual address 000280d0
pgd = ddfcc000
[000280d0] *pgd=00000000
Internal error: Oops: 5 [#1]
Modules linked in:
CPU: 0    Not tainted  ( #1)
PC is at strnlen+0x20/0x34
LR is at vsnprintf+0x314/0x5b4
pc : [<c0240228>]    lr : [<c02414f8>]    psr: a0000013
sp : dd833dc0  ip : dd833dd0  fp : dd833dcc
r10: ffffffff  r9 : ffffffff  r8 : 00000000
r7 : ffffffff  r6 : ddfac054  r5 : 000280d0  r4 : dd833e40
r3 : c00c8994  r2 : 000280d0  r1 : fffffffe  r0 : 000280d0
Flags: NzCv  IRQs on  FIQs on  Mode SVC_32  Segment user
Control: 0005317f  Table: 1dfcc000  DAC: 00000015
Process udevadm (pid: 1319, stack limit = 0xdd832268)
Stack: (0xdd833dc0 to 0xdd834000)
3dc0: dd833e1c dd833dd0 c02414f8 c0240218 0000001b 00000002 00000000 00000fce
3de0: dd833e5c 22053fab ddfac054 c00d321a dd833e44 0000001c 00000054 ddfb1000
3e00: ddfac000 dfccf0c8 00000000 c03fc7a4 dd833e38 dd833e20 c0241864 c02411f4
3e20: dfccf070 dd833e40 ddfac000 dd833eec dd833e48 c026ef10 c024184c c00d3219
3e40: 000280d0 000280d0 ddfb1000 00001000 ddfb1000 ddfb100e ddfb101d ddfb1032
3e60: ddfb103e 00000044 000280d0 c03f1574 00000000 00000000 ffffff9c c03f1574
3e80: dfd17d88 000080d0 c03f1570 ddea6040 00000000 00000000 dd833eec dd833ea8
3ea0: c01472ec c0146724 000280d0 00000010 c07ec580 dd832000 40020000 4001f000
3ec0: 00100073 df81e320 dfd17d88 dfccf070 df81e320 dfd17d88 dfccf070 df81e340
3ee0: dd833efc dd833ef0 c026e810 c026ee28 dd833f44 dd833f00 c019ca14 c026e7fc
3f00: dd833f74 dd833f10 c0153c60 dd833f70 00001000 4001f000 00000000 ddfb33a0
3f20: 4001f000 dd833f70 00001000 4001f000 dd832000 00000000 dd833f6c dd833f48
3f40: c01625e8 c019c964 00000000 00000000 00000000 00000000 ddfb33a0 00001000
3f60: dd833fa4 dd833f70 c01629fc c0162540 00000000 00000000 00000022 00000000
3f80: ffffffff 2a024c38 2a024c38 000007ff 00000003 c0027628 00000000 dd833fa8
3fa0: c0027480 c01629c8 2a024c38 2a024c38 00000007 4001f000 00001000 00000000
3fc0: 2a024c38 2a024c38 000007ff 00000003 be9734bc 0000000a 4017f000 be9734bc
3fe0: 40170000 be973418 400aab04 400fe3fc 60000010 00000007 00002031 00002431
[<c0240208>] (strnlen+0x0/0x34) from [<c02414f8>] (vsnprintf+0x314/0x5b4)
[<c02411e4>] (vsnprintf+0x0/0x5b4) from [<c0241864>] (sprintf+0x2c/0x34)
[<c0241838>] (sprintf+0x0/0x34) from [<c026ef10>] (show_uevent+0xf8/0x140)
 r3:000280d0 r2:000280d0 r1:c00d3219
[<c026ee18>] (show_uevent+0x0/0x140) from [<c026e810>] (dev_attr_show+0x24/0x28)
 r7:df81e340 r6:dfccf070 r5:dfd17d88 r4:df81e320
[<c026e7ec>] (dev_attr_show+0x0/0x28) from [<c019ca14>] (sysfs_read_file+0xc0/0x130)
[<c019c954>] (sysfs_read_file+0x0/0x130) from [<c01625e8>] (vfs_read+0xb8/0x148)
[<c0162530>] (vfs_read+0x0/0x148) from [<c01629fc>] (sys_read+0x44/0x70)
 r7:00001000 r6:ddfb33a0 r5:00000000 r4:00000000
[<c01629b8>] (sys_read+0x0/0x70) from [<c0027480>] (ret_fast_syscall+0x0/0x2c)
 r8:c0027628 r7:00000003 r6:000007ff r5:2a024c38 r4:2a024c38
Code: ea000000 e2800001 e2511001 3a000002 (e5d03000)

Ubuntu 9.04 plug0 ttyS0

plug0 login:

Art Botterell

Karma: 0
Posts: 5

View Profile
« Reply #3 on: April 26, 2009, 06:15:21 PM »

Cross-referencing another instance: http://openplug.org/plugforum/index.php?topic=167.0

Global Moderator

Karma: 0
Posts: 20

View Profile
« Reply #4 on: April 27, 2009, 04:12:55 AM »

I got the same error when installed X (during packages configuration). It basically says that system cannot handle kernel paging request. The memory was pretty full (I checked it with "free"command)
Have anyone tried to activate some swap space? I believe it may help (but not sure, didn't tested it yet).


Karma: 0
Posts: 28

View Profile
« Reply #5 on: April 27, 2009, 04:41:06 PM »

I got the same error when installed X (during packages configuration). It basically says that system cannot handle kernel paging request. The memory was pretty full (I checked it with "free"command)
Have anyone tried to activate some swap space? I believe it may help (but not sure, didn't tested it yet).

Good thought; swap space had occurred to me in the past, then I didn't consider it when this error came up.

I just 'fdisk'ed a thumb drive to provide half FAT, half Linux swap, 'mkswap'ed, 'swapon'ed, confirmed it was recognized, and tried my 'apt-get install qt4-dev-tools' again.  Alas, same error, and 'top' never showed any evidence that it was even close to filling up the existing onboard RAM, much less tried to put anything into swap.  I fear this is a separate issue...


Art Botterell

Karma: 0
Posts: 5

View Profile
« Reply #6 on: April 27, 2009, 04:55:40 PM »

I tried creating a swapfile on the SD, also with no effect.


Karma: 0
Posts: 1

View Profile
« Reply #7 on: August 14, 2009, 12:52:22 PM »

I just got my Sheeva last week and I am attempting to run X11 and Gnome. I have encountered the dreaded hal failure.
Has anyone managed to proceed past this ?

Any advice is appreciated,


Jr. Member

Karma: 0
Posts: 65

View Profile
« Reply #8 on: August 14, 2009, 01:00:53 PM »

Have you seen this?

Pages: [1]
Jump to: