• Home
  • Help
  • Search
  • Login
  • Register
Pages: 1 2 [3] 4
Author Topic: guruplug server plus arrived but died  (Read 22628 times)
guidol
Full Member
***

Karma: 10
Posts: 128



View Profile
« Reply #30 on: May 18, 2010, 01:43:28 AM »

You are correct! I've been using 1G switches .... pulled out the ol' 16 port 10/100M router and all of the sudden it works fine -- no more rebooting.
because of the fact that I didnt own a Gigabit-Switch I used my 10/100 Switch and my Network Interfaces do work also...no reboot....
Logged

Lukkie
Newbie
*

Karma: 0
Posts: 7


View Profile
« Reply #31 on: May 18, 2010, 02:23:23 AM »

because of the fact that I didnt own a Gigabit-Switch I used my 10/100 Switch and my Network Interfaces do work also...no reboot....

Right, well it fixes things for the short term, it is ofcourse not a long term solution Smiley

So, how to fix the plug so that it runs 2xGigabit without rebooting ...
Logged

daemondust
Newbie
*

Karma: 4
Posts: 23


View Profile
« Reply #32 on: May 18, 2010, 05:26:20 AM »

I can get eth0 or eth1 (I haven't tried both at the same time) to come up at 100 meg, but cycle link up/link down if I try to bring them up at 1 gig.

Is it possible to lock the speed to 100 in the plug? I am not able to change speed of the switch right now...

/Jimmy

You should be able to with mii-tool.  Something like `mii-tool -F 100baseTx-FD eth0` should work.  If that doesn't, and you have what you need, you can make an ethernet cable with only the first two pair so there's no way it can negotiate to 1 gig.  Also, sometimes mine negotiates to 100 meg on its own after a few up/down cycles at 1 gig.

I hope these problems get fixed (whether by GST or someone here I don't much care) and someone posts a good, working uboot, kernel, and RFS that works with all the plug has to offer.  I hate not being able to boot from usb or esata, but I'm not familiar enough with the architecture to build my own system yet.
« Last Edit: May 18, 2010, 05:32:40 AM by daemondust » Logged

kwadronaut
Newbie
*

Karma: 0
Posts: 3


View Profile
« Reply #33 on: May 18, 2010, 10:10:00 AM »

So it seems that I got an older version? wpa_supplicant isn't included in my root filesystem, but it seems to be the uboot version has the (not so) promising tag of 2009.11-rc1-00602-g28a9c08-dirty

I have the Plug2L reference board and not the guruplug reference board (it's a guru+). Do the people with the guruplug reference board don't have these lockups and reboots with the ethernet plugged in? And plug2l people do? Where are the differences?
Logged

Magus
Newbie
*

Karma: 1
Posts: 25


View Profile
« Reply #34 on: May 18, 2010, 11:32:15 AM »

I have had my Guru for about 2 weeks. When I got it there was no CD so I called Globalscale and they pointed me to the link to download the files. After playing around with it a bit, I had trouble getting the unit to “Client “mode. After reading the instructions on page 8 of “Quick Start Guide” I was rearing to go.
After reading your posts on the forum I decided to play around with the Ethernet connections. Noticed straight away that the unit was running a lot hotter and after around 8 minutes it rebooted by itself. I thought “dam” my unit is faulty. I then called “Globalscale”. But was advised by reception person to email support.  After 3 days I got a reply acknowledging there is a problem with the power supply, and, either I can ship the unit back for exchange or wait till they have the new version of power supplies available in June. Since I am mainly using the WiFi I have decided to wait till the new power supply is available.
I am obviously disappointed after waiting since February for my unit to have something happening like this. I am a gadget person so know the pitfalls in getting the latest and greatest inventions fresh off the production line. My first Ipod had problems with “freezing”, let’s not talk too much about “Windows Vista”, and my new Ipad will not connect with my “Apple” router. At least I can say  “Globalscale” acknowledge there is a problem and they have a plan in place to rectify the problem.
Logged

Lukkie
Newbie
*

Karma: 0
Posts: 7


View Profile
« Reply #35 on: May 18, 2010, 12:06:11 PM »

After 3 days I got a reply acknowledging there is a problem with the power supply, and, either I can ship the unit back for exchange or wait till they have the new version of power supplies available in June.

I will not believe that the problem with "not being able to connect 2 x Gigabit ethernet" is related to the power supply overheating, or did they say it has something else to do with the power supply? The reasoning is that while on the u-boot prompt just sitting there and doing nothing doesn't make my plug reboot. Working in Linux does.

Therefor I really believe it is driver related.
Logged

Stevie
Newbie
*

Karma: 0
Posts: 2


View Profile
« Reply #36 on: May 18, 2010, 02:03:42 PM »

Hi,

I got my GuruPlug Plus a week ago. I am using it with one Ethernet cable connected, Wifi sometimes on, sometimes off. The Ethernet is connected to a Fritz Box (100 Mbit). I am at 230 Volts. GuruPlug is working absolutely stable and fine since days. I am also using the Bluetooth heavily and also no problems.

The GuruPlug is warmer than my Sheeva but I would not say it's "hot".  My MacBook Pro gets much hotter - when I have booted Windows Vista, under MacOS it's cooler ;-)

The power consumption is about 3.8 Watts without Wifi and 4.3 Watts with Wifi - similar to the Sheeva.

Someone asked: Switching Wifi off is done using "uaputl bss_stop". It seems to really switch it off because of the difference in power consumption.

Stefan
Logged

MrD
Newbie
*

Karma: 1
Posts: 2


View Profile
« Reply #37 on: May 19, 2010, 01:29:18 PM »

Hello,

I've got my new GuruPlug yesterday..connected it to a GBit Ethernet Network, waited some minutes..boom, reboot after reboot.

Answer from Globalscale:

Quote
The current becomes high while connecting 1Gb Ethernet cable to Guru board,
Maybe this will cause the board to work in unstable state. Connecting to
10/100Mb will not have the reboot issue.

We know the issue and is trying to identify the root cause and find the
solution with Marvell. Once the solution is confirmed, we will inform you
(our customer).


My testresults so far:
When I use a fan which blows some air around and in the Guru it works stable, even with GBit Ethernet. When I switch off the fan and wait some minutes the "critical temperature" (whatever this is) is reached and the Guru starts with its reboots again...

So there seem to be a heat/power consumption problem...grml

Greets
  MrD
Logged

myrrh55
Newbie
*

Karma: 0
Posts: 2


View Profile
« Reply #38 on: May 20, 2010, 09:01:58 AM »

got my plug yesterday and it's rebooting too.  Running on 240V and with gigabit Ethernet reboots after a few minutes.  On the plus side with external drive plugged and 100% CPU load and streaming music over WiFi it seems stable.  It's hot but I was expecting hotter - my Macbook power brick is gets much hotter.
Logged

Stevie
Newbie
*

Karma: 0
Posts: 2


View Profile
« Reply #39 on: May 20, 2010, 10:45:57 PM »

Hi,

I got my GuruPlug Plus a week ago. I am using it with one Ethernet cable connected, Wifi sometimes on, sometimes off. The Ethernet is connected to a Fritz Box (100 Mbit).

a short update: I wanted to test the behaviour with Gigabit Ethernet. Since I do no have a Gigabit Switch I connected directly to my MacBook. And in addition I used the JTAG console to be able to observe what's going on. The Guru booted fine. As expected it had no IP address (no DHCP server). I configured it by hand and got the connection to the MacBook. The GuruPlug did never crash nor reboot nor anything suspicous over several hours. But under load it several times lost the IP address and I had to manually do ifconfig to set it again. Which always worked. So there is something fishy with the Gigabit Ethernet. Could also be software related, though.

Stefan
Logged

celandir
Newbie
*

Karma: 0
Posts: 8



View Profile
« Reply #40 on: May 21, 2010, 12:58:31 AM »

Just wanted to add my experiences:

I got my GuruPlug Server Plus on tuesday (May 18) and played around with it a lot. It's quite warm, but not hot. As others mentioned: a Mac Book Pro is much hotter ;-)

My ADSL-router supports only 100M and there are no problems at all with this connection, but as soon as I connect a cable to my Mac Book Pro, the plug resets itself and continues to reboot infinitely. When I reduce the advertised link speed for autonegotiation to max 100M (ethtool -s eth1 advertise 0x00F) I can link up to the MBP without problems, but the link speed is of course only at 100M.

I don't think this is related to temperature, because the reset happens immediately when I connect to a gigabit device. I hope this is a driver problem and someone comes up with a solution!

BTW: My supplier (dureg) confirmed that this is a known problem and they are working with GlobalScale to solve it.

In the meantime: What would be a good place to call ethtool (or mii-tool)? I could call it early in /etc/rcS.d, but then I still had to pull the cable before reboot. Does anyone know if (and how) I can pass an option to the mv643xx_eth module to limit autonegotiation?
« Last Edit: May 21, 2010, 01:56:13 AM by celandir » Logged

j.hoekstra
Newbie
*

Karma: 0
Posts: 4


View Profile
« Reply #41 on: May 21, 2010, 05:06:27 AM »

I don't think this is related to temperature, because the reset happens immediately when I connect to a gigabit device. I hope this is a driver problem and someone comes up with a solution!

BTW: My supplier (dureg) confirmed that this is a known problem and they are working with GlobalScale to solve it.

In the meantime: What would be a good place to call ethtool (or mii-tool)? I could call it early in /etc/rcS.d, but then I still had to pull the cable before reboot. Does anyone know if (and how) I can pass an option to the mv643xx_eth module to limit autonegotiation?

eth-tool can be called from /etc/network/interfaces as far as I can tell(saw a nice link yesterdat, but now unable to find it again, most examples cover redhat.

In this case it would be something like this:
auto eth0
iface eth0 inet dhcp
     pre-up [ -f /etc/network/call_to_eth_tool_with_appropiate_parameters.script]

I'm no debian-master so I might be wrong, but this seems like the best place because it seems to be run when the adapter is brought up...
Logged

sbe
Newbie
*

Karma: 0
Posts: 2


View Profile
« Reply #42 on: May 22, 2010, 01:28:47 AM »

Hello!

I received my plug a few days ago, after reading all your posts, at first I was thinking about to return it without ever switching it on. But I gave it a try.

So I'm very surprised, my plug is running fine at a 1GBit network port without any reboots, it's on since yesterday:

Quote
eth0: link up, 1000 Mb/s, full duplex, flow control disabled
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
ip_tables: (C) 2000-2006 Netfilter Core Team
nf_conntrack version 0.5.0 (8022 buckets, 32088 max)
CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
nf_conntrack.acct=1 kernel parameter, acct=1 nf_conntrack module option or
sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
eth0: no IPv6 routers present

sbeplug:~# uptime
 10:18:43 up 17:36,  2 users,  load average: 0.00, 0.00, 0.00

I was able to install cacti, setting up a database, connecting a serial device with a usb2serial converter, compile a data receiver program for my weather receiver and using it. I also connected a USB stick with 4GB space. Until now I'm very satisfied, I did not expect to make this work so fast.

My plug is connected to a D-Link DGS-1005D desktop switch. I ordered my plug through german retailer Dr.Bott.

Regards,
Stefan
« Last Edit: May 22, 2010, 07:28:46 AM by sbe » Logged

kwadronaut
Newbie
*

Karma: 0
Posts: 3


View Profile
« Reply #43 on: May 22, 2010, 03:44:12 PM »

U-boot doesn't have any troubles with the Gib link. I had it accidently on for hours doing tftp. I've put on a new u-boot from git, seems to work ok. Now I still need to flash the OS. The U-Boot doesn't understand my partitioning of the memory card. Maybe it doesn't cope well with the maximize flag? Other clues?
Logged

jseaton
Newbie
*

Karma: 0
Posts: 1


View Profile
« Reply #44 on: May 23, 2010, 10:14:04 AM »

I don't think this is related to temperature, because the reset happens immediately when I connect to a gigabit device. I hope this is a driver problem and someone comes up with a solution!

BTW: My supplier (dureg) confirmed that this is a known problem and they are working with GlobalScale to solve it.

In the meantime: What would be a good place to call ethtool (or mii-tool)? I could call it early in /etc/rcS.d, but then I still had to pull the cable before reboot. Does anyone know if (and how) I can pass an option to the mv643xx_eth module to limit autonegotiation?

eth-tool can be called from /etc/network/interfaces as far as I can tell(saw a nice link yesterdat, but now unable to find it again, most examples cover redhat.

In this case it would be something like this:
auto eth0
iface eth0 inet dhcp
     pre-up [ -f /etc/network/call_to_eth_tool_with_appropiate_parameters.script]

I'm no debian-master so I might be wrong, but this seems like the best place because it seems to be run when the adapter is brought up...


Check out: http://www.cyberciti.biz/tips/howto-linux-add-ethtool-duplex-settings-permanent.html

Red Hat is first, scroll down a bit for Debian.
Logged

Pages: 1 2 [3] 4
Print
Jump to: