• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: CRC Errors on boot.  (Read 2575 times)

Karma: 0
Posts: 17

View Profile
« on: April 24, 2009, 09:33:32 AM »

Brief history, everything was running fine for about 2 weeks but I needed serial support for an external ftdi board.  I updated to the  2.6.30-rc3 image.  It would not boot properly after setting the env vars and saving.  I made several attempts to get tftp working to boot a remote image I have stored on my linux machine.  I noticed finally that the settings I was adding were not saving properly setenv ipaddr= left me without an variable for ipaddr when I ran printenv.  I decided at this point to run resetenv and go for the usb recovery and see if i could get back to the starting point.  I ran resetenv then reset and uppon the reboot it began running tests which I assumed were just part of the resetenv process.  After it completed i was sitll having trouble booting and the kernel locks up so I reset.  Now it runs these lengthy tests at every boot and I noticed it says NAND: Nand ECC error then begins the tests.

All the tests pass with the following locations marked as bad blocks in the nand: 0fbe0000, 15660000, and 1f300000.  None of these look particularly important to me and after reading up on the 4bit vs 1bit crc methods.  Is it possible the CRC is just wrong or these bad blocks are causing my headache and how can I get my env vars to save.  Everything seems straight forward enough but all the trouble this is giving me feels like something else might be wrong.

Global Moderator
Full Member

Karma: 0
Posts: 139

View Profile
« Reply #1 on: April 24, 2009, 10:47:52 AM »

Useful setting:



Pages: [1]
Jump to: