• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: FTP - too slow  (Read 2795 times)
vkashesh
Newbie
*

Karma: 0
Posts: 34


View Profile
« on: April 06, 2010, 09:05:16 AM »

Hi all,
I've been experiencing this extremely annoying problem and it has to do with FTP.  I try to use the FTP to connect to the SheevaPlug (running  kernel 2.6.30-rc6 and Ubuntu 9.04) but the connection doesn't always happen, and when it does, sometimes it takes over a minute to transfer a 10KByte file.

Is this a known problem?
Can anyone recommend a different FTP server to install on the plug?

Thanks in advance
Logged

Abra
Newbie
*

Karma: 1
Posts: 29


View Profile
« Reply #1 on: April 06, 2010, 10:10:03 AM »

I use pure-ftpd, it works perfectly, and it is quite easy to configure.
Transfer rate is about 45/50MB/s when connected directly to another computer via (gigabit) ethernet.
What is the link between the computer and the sheevaplug, when you're experiencing problems?
Also, what's your current ftp server?
Logged

Abra
Newbie
*

Karma: 1
Posts: 29


View Profile
« Reply #2 on: April 06, 2010, 10:12:25 AM »

I forgot to mention I use an esata sheevaplug (with esata). You may not be able to reach this speed via usb or sd card.
Logged

vkashesh
Newbie
*

Karma: 0
Posts: 34


View Profile
« Reply #3 on: April 06, 2010, 10:21:12 AM »

Thanks Abra.
I am using TFTP and I am not going through the USB or SDCARD, I am going through the Ethernet.  I am not looking to achieve high transfer speeds but I want to be able to use FTP to transfer files instead of copying them on USB stick to transfer, and to run in command line over ssh instead of serial port with hyper terminal.

I will try to install pure-ftp and see what happens.

Thanks again for the suggestion. 
Logged

birdman
Sr. Member
****

Karma: 4
Posts: 440


View Profile WWW
« Reply #4 on: April 06, 2010, 01:12:30 PM »

I am using TFTP
TFTP isn't FTP.  Which are you using?
Quote
.. but I want to be able to use FTP to transfer files instead of copying them on USB stick to transfer, and to run in command line over ssh instead of serial port with hyper terminal.
If you intend to use slogin (i.e. ssh) then why not use sftp, which uses the same daemons and setup.[/quote]
Quote
I will try to install pure-ftp and see what happens.
So what are you using now for the server?
Logged

vkashesh
Newbie
*

Karma: 0
Posts: 34


View Profile
« Reply #5 on: April 10, 2010, 04:20:30 PM »

I am using TFTP
TFTP isn't FTP.  Which are you using?
Quote
.. but I want to be able to use FTP to transfer files instead of copying them on USB stick to transfer, and to run in command line over ssh instead of serial port with hyper terminal.
If you intend to use slogin (i.e. ssh) then why not use sftp, which uses the same daemons and setup.
Quote
I will try to install pure-ftp and see what happens.
So what are you using now for the server?
[/quote]

Thanks for your reply.  At the moment, I am trying to diagnose a problem that I am not sure what it is just yet.  I installed pure-FTP as my server but the original problem is not going away. 

My original problem is that when I used to ftp into the Plug, the connection takes forever to get established, if it doesn't time out.  Also, when I do have a connection, it also takes a long time to transfer files.  I thought maybe the current FTP server (that came with the plug) isn't behaving properly.  But now, that pure-FTP is behaving exactly the same, I am starting the beleive that something else is wrong.  I have 2 plugs that behave the same so I am not ruling that it is a hardware issue.... something else is not right.

Any suggestions how to proceed?

« Last Edit: April 10, 2010, 04:22:40 PM by vkashesh » Logged

pingtoo
Sr. Member
****

Karma: 15
Posts: 318


View Profile
« Reply #6 on: April 10, 2010, 09:20:27 PM »

I guess you have network problem. Nothing wrong with your plug or your ftp server program. Base on your post on the hardware section you indicate your have 3 plugs with same MAC address. Do they happen to be on same network? if they do than it will explain why your ftp session slowness, actually I am bit of surprise that it even work if my guess is true.

If my guess is true than you need to make sure each of your plug have unique MAC address. you should be able to get it from back of your plug. At u-boot prompt use setenv ethaddr <MAC address>; saveenv to change it.

Good luck Smiley
Logged

Good Luck Smiley

vkashesh
Newbie
*

Karma: 0
Posts: 34


View Profile
« Reply #7 on: April 11, 2010, 11:39:16 AM »

hi pingtoo,
Thanks for the suggestion.  Although I currently have one connected to the network, but I think getting the MAC addresses straightened out is an important step.

How can I get to the u-boot prompt? 

Is it during bootup where the plug counts 3 second waiting for me to hit any key? I tried that but it doesn't work... not matter what keys I hit, the countdown completes and Linux starts up.

thanks!
Logged

pingtoo
Sr. Member
****

Karma: 15
Posts: 318


View Profile
« Reply #8 on: April 11, 2010, 02:55:55 PM »

You are correct that at 3 seconds count down is where you should be able to break in to u-boot. I am not sure why keyboard does not work for you. this may have to do with serial connection setup which is something I have very little know how. hopefully some one else can step in to help you fix this problem first.

Ping,.
Logged

Good Luck Smiley

birdman
Sr. Member
****

Karma: 4
Posts: 440


View Profile WWW
« Reply #9 on: April 11, 2010, 04:33:29 PM »

How can I get to the u-boot prompt? 
In the meantime you can fix them by adding the right addresses (i.e. what the sticker on the box says) with:
Quote
hwaddress ether 00:50:43:xx:xx:xx
lines to the iface sections in /etc/network/interfaces                          

Logged

vkashesh
Newbie
*

Karma: 0
Posts: 34


View Profile
« Reply #10 on: April 12, 2010, 08:03:09 AM »

How can I get to the u-boot prompt? 
In the meantime you can fix them by adding the right addresses (i.e. what the sticker on the box says) with:
Quote
hwaddress ether 00:50:43:xx:xx:xx
lines to the iface sections in /etc/network/interfaces                          


thanks birdman
this temporarily fixed my MAC address.  However, FTP is still not working properly...
I guess at this moment, I have two issues:
1. FTP not working
2. U-Boot inaccessible (I am wondering if the comment made by pingtoo about the serial connection is what I need to change.... maybe the u-boot needs different settings??)
Logged

hausschuh
Newbie
*

Karma: 0
Posts: 33


View Profile
« Reply #11 on: May 09, 2010, 06:03:02 AM »

Have you tried to use a crossover cable to connect to the sheeva without any other components in between?

I had a similar problem with a remote server. It was a problem with the passive mode and the port forwarding. Note that you need 2 ports for FTP. Standard port for the commands is 21 and the transfer port is 20.
Logged

Trune
Jr. Member
**

Karma: 3
Posts: 70


View Profile
« Reply #12 on: May 16, 2010, 01:09:57 PM »

I use pure-ftpd, it works perfectly, and it is quite easy to configure.
Transfer rate is about 45/50MB/s when connected directly to another computer via (gigabit) ethernet.
What is the link between the computer and the sheevaplug, when you're experiencing problems?
Also, what's your current ftp server?

45/50mb/s ? what device are you writing / reading on the sheeva to get that?
Logged

Pages: [1]
Print
Jump to: