• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: Wireless Through USB Hub  (Read 2500 times)

Karma: 0
Posts: 1

View Profile
« on: March 19, 2010, 03:24:26 PM »

Hi all,

First, I sincerely apologize if this is a duplicate topic, I searched the forum and Google to no avail although it's possible I was using the wrong terms.

Also, I would say that I'm somewhat of a linux newbie, I'm not totally wet behind the ears, but I'd say I'm slightly damp...

Now, I'm trying to connect my SheevaPlug to a wireless network using the WG111v2 usb stick. I've upgraded my plug using the Installer v1.0 and it works beautifully when it is plugged directly into the device's USB port.  However, for the project I'm working on, I need to be able to connect multiple (specifically 2) devices to the plug computer at a time and I bought an el-cheapo usb hub to accomplish this.  I fist got the Wi-Fi working directly connected to the plug and then plugged it in to the usb hub.  Yesterday, it worked just fine, but today, I haven't been able to get it to associate. 

My first thought was that the USB hub was interfering with the plug's ability to connect to the Wi-Fi dongle (I read there were some issues with usb hubs on the sheeva) so I used lsusb and got:

root@ubuntu:~# lsusb
Bus 001 Device 007: ID 0846:6a00 NetGear, Inc. WG111 WiFi (v2)
Bus 001 Device 005: ID 0e8f:0016 GreenAsia Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Which is perfectly accurate.

I can scan for networks and see the correct network:

root@ubuntu:~# iwlist wlan0 scan
wlan0     Scan completed :
          Cell 01 - Address: 00:17:0F:DA:E0:60
                    Frequency:2.412 GHz (Channel 1)
                    Quality=43/70  Signal level=-67 dBm
                    Encryption key:off
                    Bit Rates:11 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra: Last beacon: 2050ms ago
                    IE: Unknown: 000100
                    IE: Unknown: 010396606C
                    IE: Unknown: 030101
                    IE: Unknown: 2A0100
                    IE: Unknown: 851E00008C000F00FF031900737461706C65746F6E2D61702D342E0002000027
                    IE: Unknown: 9606004096001400
                    IE: Unknown: DD06004096010100
                    IE: Unknown: DD050040960304
                    IE: Unknown: DD1600409604000207A4000023A400004243000062320000
                    IE: Unknown: DD050040960B01
                    IE: Unknown: DD180050F2020101820003A4000027A4000042435E0062322F00

*Note the SSID is hidden and I have the correct SSID configured in the /etc/network/interfaces file*

It just never associates.  The iwconfig for the interface looks like

root@ubuntu:~# iwconfig wlan0
wlan0     IEEE 802.11bg  ESSID:"vummiv"
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Tx-Power=27 dBm
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

And I know that the network is in range because I have other devices connected to it and the adapter is in the same physical location as when it worked (also if I remove it from the hub and plug it directly into the plug computer, it works just fine).

So I'm stumped.  Anybody have any thoughts or experience with this?

Thanks in advance,


Karma: 2
Posts: 34

View Profile
« Reply #1 on: March 19, 2010, 06:44:03 PM »

1- have you tried powering your hub ? it seems the plug's PSU is extremely weak.

2- do you have another hub to try ? most hubs are terribad, it seems DLink is the favored brand here.

3- I don't know enough about Linux to help you with OS stuff, but I'd really go for the hardware stuff first. Can you check if connecting the dongle well after the boot is completed solves the issue ? not that it's a long-term solution, but it means that maybe you should delay enabling the dongle until after all other boot processes have completed, for power or other reasons.

good luck.


Sr. Member

Karma: 4
Posts: 443

View Profile WWW
« Reply #2 on: March 19, 2010, 07:26:00 PM »

I fist got the Wi-Fi working directly connected to the plug and then plugged it in to the usb hub.
You might want to set that up again and do a scan with a direct connexion since
Quote from: same again
                    Quality=43/70  Signal level=-67 dBm
that is a very low signal level.  Mine (a RTL8187B chipset Wifi dongle) gets this
                    Quality=70/70  Signal level=-6 dBm
and I only run the power at 20dBm (100mW).  However, I have recently (yesterday) noticed that if I don't power the hub the signal gets weaker - particularly when used.  I have a 4-port Belkin hub.

Pages: [1]
Jump to: