• Home
  • Help
  • Search
  • Login
  • Register
Pages: 1 [2]
Author Topic: 2.6.30-rc2 and 2.6.30-rc3 new releases  (Read 10698 times)
plugit
Global Moderator
Full Member
*****

Karma: 0
Posts: 139



View Profile
« Reply #15 on: April 30, 2009, 05:51:47 AM »


I just wanted to say thanks for your efforts, cbxbiker61! I installed 2.6.22.19 yesterday by simply running your script in the readme, and it worked flawlessly.

Great stuff!
Logged

shadowace
Newbie
*

Karma: 0
Posts: 8


View Profile
« Reply #16 on: April 30, 2009, 07:21:24 AM »

Let me offer a hearty second.  It solved my problem of not having FUSE support in the original kernel.  My 1-wire stuff works great now.
Logged

cbxbiker61
Global Moderator
Sr. Member
*****

Karma: 38
Posts: 497


View Profile
« Reply #17 on: April 30, 2009, 08:13:57 AM »

Thank you both for your comments.  It's nice to know my kernels are being used.  It's also nice to know the installer (README) is working as advertised.
Logged

dumper
Newbie
*

Karma: 0
Posts: 19


View Profile
« Reply #18 on: May 22, 2009, 08:31:13 AM »

i tried to flash the new kernel yesterday, resized mtd1, boot from tftp & nfs : ok,
reboot from nand :kernel papic:

Code:
List of all partitions:
1f00            1024 mtdblock0 (driver?)
1f01            4096 mtdblock1 (driver?)
1f02          519168 mtdblock2 (driver?)
No filesystem could mount root, tried:  ext3 ext2 ext4 cramfs vfat msdos jfs
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,2)
[<c00309c0>] (unwind_backtrace+0x0/0xe0) from [<c003db20>] (panic+0x50/0x120)
[<c003db20>] (panic+0x50/0x120) from [<c0008ec4>] (mount_block_root+0x1d4/0x214)
[<c0008ec4>] (mount_block_root+0x1d4/0x214) from [<c000916c>] (prepare_namespace+0x16c/0x1c4)
[<c000916c>] (prepare_namespace+0x16c/0x1c4) from [<c0008734>] (kernel_init+0xc0/0xec)
[<c0008734>] (kernel_init+0xc0/0xec) from [<c0040b18>] (do_exit+0x0/0x6ac)


my uboot configs:

Code:
List of all partitions:
1f00            1024 mtdblock0 (driver?)
1f01            4096 mtdblock1 (driver?)
1f02          519168 mtdblock2 (driver?)
No filesystem could mount root, tried:  ext3 ext2 ext4 cramfs vfat msdos jfs
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,2)
[<c00309c0>] (unwind_backtrace+0x0/0xe0) from [<c003db20>] (panic+0x50/0x120)
[<c003db20>] (panic+0x50/0x120) from [<c0008ec4>] (mount_block_root+0x1d4/0x214)
[<c0008ec4>] (mount_block_root+0x1d4/0x214) from [<c000916c>] (prepare_namespace+0x16c/0x1c4)
[<c000916c>] (prepare_namespace+0x16c/0x1c4) from [<c0008734>] (kernel_init+0xc0/0xec)
[<c0008734>] (kernel_init+0xc0/0xec) from [<c0040b18>] (do_exit+0x0/0x6ac)


any ideas what.s wrong ?

thanx again for the efforts.
Logged

Silvio
Newbie
*

Karma: 0
Posts: 5


View Profile
« Reply #19 on: May 22, 2009, 08:39:16 AM »

Can you post your u-boot configuration? Looks like the rootfstype is missing or you are using the wrong partition. Try adding "rootfstype=jffs2" to the boot parameters.
Logged

dumper
Newbie
*

Karma: 0
Posts: 19


View Profile
« Reply #20 on: May 22, 2009, 08:42:20 AM »

Code:
Marvell>> printenv
baudrate=115200
loads_echo=0
CASset=min
MALLOC_len=1
ethprime=egiga0
bootargs_end=:::DB88FXX81:eth0:none
standalone=fsload 0x2000000 $(image_name);setenv bootargs $(console) root=/dev/mtdblock0 rw ip=$(ipaddr):$(serverip)$(bootargs_end) $(mvPhoneConfig); bootm 0x2000000;
ethaddr=00:50:43:b8:30:19
ethmtu=1500
mvPhoneConfig=mv_phone_config=dev0:fxs,dev1:fxs
mvNetConfig=mv_net_config=(00:11:88:0f:62:81,0:1:2:3),mtu=1500
usb0Mode=host
yuk_ethaddr=00:00:00:EE:51:81
nandEcc=1bit
netretry=no
rcvrip=169.254.100.100
loadaddr=0x02000000
autoload=no
ethact=egiga0
ipaddr=10.0.1.49
netmask=255.255.255.0
gatewayip=10.0.1.2
serverip=10.0.1.16
rootpath=/home/sheevaplug
image_name=uImage
bootargs_root=root=/dev/nfs rw
console=console=ttyS0,115200 mtdparts=nand_mtd:0x100000@0x000000(u-boot),0x00500000@0x00100000(uImage),0x1fa00000@0x00600000(rootfs)rw
bootargs=console=ttyS0,115200 mtdparts=nand_mtd:0x100000@0x000000(u-boot),0x00500000@0x00100000(uImage),0x1fa00000@0x00600000(rootfs)rw root=/dev/mtdblock2
bootcmd=nand read.e 0x8000000 0x100000 0x500000;bootm 0x8000000
arcNumber=2097
stdin=serial
stdout=serial
stderr=serial
mainlineLinux=yes
enaMonExt=no
enaCpuStream=no
enaWrAllo=no
pexMode=RC
disL2Cache=no
setL2CacheWT=yes
disL2Prefetch=yes
enaICPref=yes
enaDCPref=yes
sata_dma_mode=yes
netbsd_en=no
vxworks_en=no
bootdelay=3
disaMvPnp=no
enaAutoRecovery=yes

Environment size: 1360/131068 bytes



anyway , i guessed i posted in the wrong section since the kerner version was sheeva-2.6.30-rc6.

Logged

dumper
Newbie
*

Karma: 0
Posts: 19


View Profile
« Reply #21 on: May 22, 2009, 08:50:16 AM »

works now, thanx for thi hints with rootfstype=jffs2

some errors though:
Code:
[ OK ]ting preliminary keymap...       
 * Setting the system clock
modprobe: FATAL: Could not load /lib/modules/2.6.30-rc6/modules.dep: No such file or directory

Cannot access the Hardware Clock via any known method.
Use the --debug option to see the details of our search for an access method.
 * Unable to set System Clock to: Fri May 22 15:46:12 UTC 2009
[ OK ]rting basic networking...       
[ OK ]rting kernel event manager...       
 * Loading hardware drivers...        uncorrectable error : <3>uncorrectable error : <3>end_request: I/O error, dev mtdblock0, sector 0
Buffer I/O error on device mtdblock0, logical block 0
uncorrectable error : <3>uncorrectable error : <3>end_request: I/O error, dev mtdblock0, sector 8
Buffer I/O error on device mtdblock0, logical block 1
uncorrectable error : <3>uncorrectable error : <3>end_request: I/O error, dev mtdblock0, sector 16
Buffer I/O error on device mtdblock0, logical block 2
uncorrectable error : <3>uncorrectable error : <3>end_request: I/O error, dev mtdblock0, sector 24
Buffer I/O error on device mtdblock0, logical block 3
uncorrectable error : <3>uncorrectable error : <3>end_request: I/O error, dev mtdblock0, sector 0
Buffer I/O error on device mtdblock0, logical block 0
[ OK ]
 * Setting the system clock
[ OK ]ding kernel modules...         * Loading manual drivers...       
[ OK ]ting kernel variables (/etc/sysctl.conf)...       
[ OK ]ting kernel variables (/etc/sysctl.d/10-console-messages.conf)...       
[ OK ]ting kernel variables (/etc/sysctl.d/10-network-security.conf)...       
 * Setting kernel variables (/etc/sysctl.d/10-process-security.conf)...        error: "vm.mmap_min_addr" is an unknown key
[fail]
[ OK ]ting kernel variables (/etc/sysctl.d/10-tcp-timestamps-workaround.conf)...       
[ OK ]ivating swap...       
 * Reloading /etc/samba/smb.conf smbd only
modprobe: FATAL: Could not load /lib/modules/2.6.30-rc6/modules.dep: No such file or directory

modprobe: FATAL: Could not load /lib/modules/2.6.30-rc6/modules.dep: No such file or directory

FATAL: Could not load /lib/modules/2.6.30-rc6/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.30-rc6/modules.dep: No such file or directory
[ OK ]rting early crypto disks...       
FATAL: Could not load /lib/modules/2.6.30-rc6/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.30-rc6/modules.dep: No such file or directory
[ OK ]rting remaining crypto disks...       
 * Checking file systems...        fsck 1.41.3 (12-Oct-2008)
[ OK ]
[ OK ]nting local filesystems...       
[ OK ]ivating swapfile swap...       
[ OK ]figuring network interfaces...       
[ OK ]ting up console font and keymap...       
 * Starting system log daemon...       
Ubuntu jaunty (development branch) debian ttyS0

[ OK ] login:
[ OK ] * Starting kernel log daemon...       
[ OK ] * Starting OpenBSD Secure Shell server sshd       
[ OK ] * Starting periodic command scheduler crond       
      fat: version magic '2.6.22.18 mod_unload ARMv5 ' should be '2.6.30-rc6 preempt mod_unload ARMv5 '
insmod: error inserting '/boot/fat.ko': -1 Invalid module format

Ubuntu jaunty (development branch) debian ttyS0

Logged

Silvio
Newbie
*

Karma: 0
Posts: 5


View Profile
« Reply #22 on: May 22, 2009, 12:50:18 PM »

The errors is because the modules were not created for kernel 2.6.30-rc6. If you are using a kernel with modules, install the modules and you should have a /lib/modules/2.6.30-rc6 directory. If the kernel has no modules, just do a 'depmod -a' as root and it should fix the error messages.
Logged

Pages: 1 [2]
Print
Jump to: