• Home
  • Help
  • Search
  • Login
  • Register
Pages: 1 [2]
Author Topic: Need original bootcmd  (Read 9526 times)
plugit
Global Moderator
Full Member
*****

Karma: 0
Posts: 139



View Profile
« Reply #15 on: April 23, 2009, 11:52:11 AM »

Ha! You missed this discussion:

http://openplug.org/plugforum/index.php?topic=49.msg312#msg312

Took me hours to figure out that it was the image!
Logged

Pandemonium
Newbie
*

Karma: 0
Posts: 37


View Profile
« Reply #16 on: April 23, 2009, 12:37:31 PM »

Gah.

There needs to be a public announcement somewhere.
Logged

crasmus
Newbie
*

Karma: 0
Posts: 6


View Profile
« Reply #17 on: May 09, 2009, 10:27:30 AM »

I think I have a corrupted kernel!
After bootind (and NOT working) I did print & Here it is.
USB 0: host mode
PEX 0: interface detected no Link.
Net:   egiga0 [PRIME], egiga1
Hit any key to stop autoboot:  0
Marvell>> print
baudrate=115200
loads_echo=0
netmask=255.255.255.0
CASset=min
MALLOC_len=1
ethprime=egiga0
bootargs_end=:::DB88FXX81:eth0:none
standalone=fsload 0x2000000 $(image_name);setenv bootargs $(console) root=/dev/m
tdblock0 rw ip=$(ipaddr):$(serverip)$(bootargs_end) $(mvPhoneConfig); bootm 0x20
00000;
ethaddr=00:50:43:10:36:05
ethmtu=1500
mvPhoneConfig=mv_phone_config=dev0:fxs,dev1:fxs
mvNetConfig=mv_net_config=(00:11:88:0f:62:81,0:1:2:3),mtu=1500
usb0Mode=host
yuk_ethaddr=00:00:00:EE:51:81
nandEcc=1bit
netretry=no
rcvrip=169.254.100.100
autoload=no
loadaddr=0x2000000
mtd1Size=0x300000
arcNumber=2097
bootcmd_usb=usb start; ext2load usb 0:1 0x0800000 /boot/uInitrd; ext2load usb 0:
1 0x400000 /boot/uImage
bootfile=uImage
ipaddr=192.168.0.63
serverip=192.168.0.61
rootpath=home/rootfsv1.0
image_name=ulmage.sheeva.040309
console=console=ttyS0.115200 mtdparts=:0x100000(u-boot),0x300000@x100000(ulimage
),0x1fc00000@0x400000(rootfs)rw
bootargs_root=root=/dev/nfs rw
ethact=egiga0
filesize=1000
bootargs=console=ttyS0,115200 mtdparts=nand_mtd:0x100000@0x00000(u-boot),0x30000
0@0x100000(uImage)ro,0x1fc00000@0x400000(rootfs)rw root=/dev/mtdblock2
bootcmd=nand read.e 0x800000 0x100000 0x300000; bootm 0x800000
stdin=serial
stdout=serial
stderr=serial
mainlineLinux=yes
enaMonExt=no
enaCpuStream=no
enaWrAllo=no
pexMode=RC
disL2Cache=no
setL2CacheWT=yes
disL2Prefetch=yes
enaICPref=yes
enaDCPref=yes
sata_dma_mode=yes
netbsd_en=no
vxworks_en=no
bootdelay=3
disaMvPnp=no
enaAutoRecovery=yes

Environment size: 1482/131068 bytes
Marvell>>

Any help?

Please help me not waste $100.00 US....
Logged

plugcomp
Newbie
*

Karma: 0
Posts: 18


View Profile
« Reply #18 on: May 12, 2009, 04:18:55 PM »

From the logs, it seems that you have not set the variables for USB recovery correctly.

Do the following at the U-Boot prompt and let us know how it goes:
Marvell>> set mtd1Size 0x300000
Marvell>> set filesize 0x44ad000
Marvell>> saveenv
Marvell>> reset

Again confirm, that the above parameters are set by giving a 'print' command:
Marvell>> print mtd1Size

Plug in the USB stick that has the following: flashware.img, uImage.sheeva.040309 and ubuntu-9.0.5.Release.jffs2.

Then issue the following command at uboot prompt:
Marvell>> rcvr
Logged

Pages: 1 [2]
Print
Jump to: