• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: ext2load hanging  (Read 1306 times)
Tempel
Newbie
*

Karma: 0
Posts: 11


View Profile WWW
« on: January 13, 2010, 11:24:20 PM »

Hi everybody.

On realizing that Ubuntu support would eventually end, I decided to give Arch mobile a try on my plug, following these instructions to the letter.  However, the boot sequence just prints out the results of mmcinit, then hangs (for at least 5 minutes or so; that's the longest I've waited).  Entering the commands manually seems to work perfectly up until the ext2load command, which simply does not respond at all.  In case you're wondering, ext2ls can see the files just fine.

I haven't seen any mention of this problem elsewhere and am at a loss.  If this is new, can I get it named after me?
Logged

Tobi
Newbie
*

Karma: 0
Posts: 1


View Profile
« Reply #1 on: January 18, 2010, 03:09:45 AM »

Hi Tempel,
I had the same problem until I read somewhere that the adresses have six zeros at the end:
Code:
setenv bootcmd_mmc 'mmcinit; ext2load mmc 0 0x4000000 /uImage'
setenv bootcmd 'setenv bootargs $(bootargs_console) $(bootargs_root); run bootcmd_mmc; bootm 0x004000000'

HTH
Logged

oreo
Newbie
*

Karma: 0
Posts: 4


View Profile
« Reply #2 on: January 18, 2010, 02:53:01 PM »

Hi Tempel,

I also have archmobile installed on the sheevaplug, and had the same problem as well.
By loading the kernel at an address with a higher value, as Tobi said, will do the trick.
Logged

Pages: [1]
Print
Jump to: