• Home
  • Help
  • Search
  • Login
  • Register
Pages: 1 [2]
Author Topic: X11 on the plug  (Read 9996 times)
jmknapp
Newbie
*

Karma: 0
Posts: 45



View Profile
« Reply #15 on: July 16, 2009, 12:39:27 PM »

1.) the keyboard layout does not map correctly from my vnc client to the vnc server.  When I type 'asdf', I get 'abfh'  I've tried to find a solution via Google... no luck yet.  Hopefully someone has seen and resolved this before?

I had that issue too... weird thing, but an easy fix. See this web page:

http://blog.yclian.com/2007/12/3-solutions-to-gnomevnc-keyboard.html

Bottom line, this is the easiest solution--just execute this from the command line:

# gconftool --set /desktop/gnome/peripherals/keyboard/kbd/layouts --type List --list-type String [aa]

Joe
Logged

mike
Jr. Member
**

Karma: 2
Posts: 55


View Profile
« Reply #16 on: July 16, 2009, 02:08:17 PM »

saw this link - http://blog.yclian.com/2007/12/3-solutions-to-gnomevnc-keyboard.html

Strange... the last line in the ./.vnc/xstartup file was '/etc/X11/Xsession'  and *not* 'gnome-session &'

changing this line made it work...

all set now

maybe it will help someone else
Logged

Rabeeh Khoury
Administrator
Full Member
*****

Karma: 5
Posts: 218


View Profile
« Reply #17 on: July 17, 2009, 12:05:58 PM »

what is the keyboard issue?

i tried it once and worked without issues.

do you have the keymap configured correctly? (i think once you are asked you should leave that to what apt-get defaults to).
Logged

mail4asim
Newbie
*

Karma: 0
Posts: 39



View Profile
« Reply #18 on: December 31, 2009, 03:47:42 AM »

Could you please post your xstartup file here. I am a newbie and need some help setting up mine.


here is what mind shows

#!/bin/sh

xrdb $HOME/.Xresources
xsetroot -solid grey
#x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#x-window-manager &
/etc/X11/Xsession



--- 

Thank you,

Asim
Logged

Pages: 1 [2]
Print
Jump to: