• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1]
Author Topic: "Bad Magic Number" after u-boot.bin update  (Read 5036 times)
jdonth
Jr. Member
**

Karma: 0
Posts: 75

Azle, Texas


View Profile
« on: December 25, 2009, 12:25:28 PM »

I set out to install Debian on my plug via Martin's  web page ( http://www.cyrius.com/debian/kirkwood/sheevaplug/install.html ).

I did not have the latest u-boot so I went to ( http://www.cyrius.com/debian/kirkwood/sheevaplug/uboot-upgrade.html ) and followed the usb upgrade method:
Code:
usb start
fatload usb 0:1 0x0800000 uboot.bin
nand erase 0x0 0xa0000
nand write 0x0800000 0x0 0xa0000

After a reboot, I am getting "Bad Magic Number". I had previously used the Alpha-6 installer and that has worked perfectly. I'm thinking it has to do with my nand partitions?

Any thoughts?

Thanks,
~Joe
Logged

...I've always depended on the kindness of strangers

tbm
Full Member
***

Karma: 7
Posts: 121



View Profile WWW
« Reply #1 on: December 25, 2009, 02:10:33 PM »

Can you post the full boot log?  And the output of "printenv"?
Logged

jdonth
Jr. Member
**

Karma: 0
Posts: 75

Azle, Texas


View Profile
« Reply #2 on: December 26, 2009, 08:47:39 AM »

When I booted the plug this morning, I'm not getting the "bad Magic Number" but it is still not working.

My boot code:
Code:
_     ____              _
| | | |   | __ )  ___   ___ | |_
| | | |___|  _ \ / _ \ / _ \| __|
| |_| |___| |_) | (_) | (_) | |_
 \___/    |____/ \___/ \___/ \__|
 ** MARVELL BOARD: SHEEVA PLUG LE

U-Boot 1.1.4 (Sep 14 2009 - 15:36:37) Marvell version: 3.4.19

U-Boot code: 00600000 -> 0067FFF0  BSS: -> 006CFB00

Soc: 88F6281 A0 (DDR2)
CPU running @ 1200Mhz L2 running @ 400Mhz
SysClock = 400Mhz , TClock = 200Mhz

DRAM CAS Latency = 5 tRP = 5 tRAS = 18 tRCD=6
DRAM CS[0] base 0x00000000   size 256MB
DRAM CS[1] base 0x10000000   size 256MB
DRAM Total size 512MB  16bit width
Addresses 8M - 0M are saved for the U-Boot usage.
Mem malloc Initialization (8M - 7M): Done
NAND:512 MB
*** Warning - bad CRC or NAND, using default environment

Flash:  0 kB

CPU : Marvell Feroceon (Rev 1)

Streaming disabled
Write allocate disabled


USB 0: host mode
PEX 0: interface detected no Link.
Net:   egiga0 [PRIME], egiga1
Hit any key to stop autoboot:  0
egiga0 no link
mvEgigaInit: egiga1 mvEthPortEnable failed (error)
mvEgigaInit: egiga1 failed
Using egiga0 device
TFTP from server 10.4.50.5; our IP address is 10.4.50.165
Filename 'uImage'.
Load address: 0x2000000
Loading: T T T
Abort
Marvell>>
and the Environment variables.
Code:
printenv
baudrate=115200
loads_echo=0
ipaddr=10.4.50.165
serverip=10.4.50.5
rootpath=/mnt/ARM_FS/
netmask=255.255.255.0
run_diag=yes
stdin=serial
stdout=serial
stderr=serial
console=console=ttyS0,115200 mtdparts=nand_mtd:0xc0000@0(uboot)ro,0x1ff00000@0x100000(root)
mainlineLinux=no
CASset=min
enaMonExt=no
enaCpuStream=no
enaWrAllo=no
pexMode=RC
disL2Cache=no
setL2CacheWT=yes
disL2Prefetch=yes
enaICPref=yes
enaDCPref=yes
sata_dma_mode=yes
MALLOC_len=1
ethprime=egiga0
netbsd_en=no
vxworks_en=no
bootargs_root=root=/dev/nfs rw
bootargs_end=:::DB88FXX81:eth0:none
image_name=uImage
bootcmd=tftpboot 0x2000000 $(image_name); setenv bootargs $(console) $(bootargs_root) nfsroot=$(serverip):$(rootpath) ip=$(ipaddr):$
(serverip)$(bootargs_end) $(mvNetConfig) $(mvPhoneConfig);  bootm 0x2000000;
standalone=fsload 0x2000000 $(image_name);setenv bootargs $(console) root=/dev/mtdblock0 rw ip=$(ipaddr):$(serverip)$(bootargs_end)
$(mvPhoneConfig); bootm 0x2000000;
bootdelay=3
disaMvPnp=no
ethaddr=00:50:43:c8:08:19
ethmtu=1500
mvPhoneConfig=mv_phone_config=dev0:fxs,dev1:fxs
mvNetConfig=mv_net_config=(00:11:88:0f:62:81,0:1:2:3),mtu=1500
usb0Mode=host
yuk_ethaddr=00:00:00:EE:51:81
nandEcc=1bit
netretry=no
rcvrip=169.254.100.100
loadaddr=0x02000000
autoload=no
enaAutoRecovery=yes
pcieTune=no
ethact=egiga0

Environment size: 1295/131068 bytes
Marvell>>

Any assistance would be greatly appreciated.

Thanks,
~Joe
Logged

...I've always depended on the kindness of strangers

tbm
Full Member
***

Karma: 7
Posts: 121



View Profile WWW
« Reply #3 on: December 27, 2009, 02:12:08 AM »

Your u-boot is configured to boot from a TFTP server, which you probably don't have.  I guess you let the u-boot upgrade process overwrite the u-boot config (which you shouldn't have done).

Anyway, you can simply follow the instructions to install Debian and it will work.  If you want to boot from the OS in flash, you have to read this forum to find out how to configure u-boot (I don't know off-hand).

Logged

Pages: [1]
Print
Jump to: