• Home
  • Help
  • Search
  • Login
  • Register
Pages: 1 ... 6 7 [8] 9 10
 71 
 on: September 25, 2013, 01:45:24 PM 
Started by cbxbiker61 - Last post by birdman
Yippee!!  One down!!!

I've built 3.10.6 (I was running 3.10.5, and wanted something close, but with no danger of a name-space clash).
All I've done is changed this in kirkwood-3.10.6.config
Quote
#GML -  CONFIG_SERIAL_OF_PLATFORM is not set
CONFIG_SERIAL_OF_PLATFORM=y
and I now have a working serial console again!

Well, I got a full set of boot up messages.  I didn't get the console prompt until I re-enabled the TO/getty line in inittab and ran "telinit q".  (I'd disabled as it was producing message about re-=spawning too quickly.).  That all works now.

It still doesn't auto-boot on power-on, though :-(.

PS:  I forgot to mention that the nice thing about using VirtualBox+qemu is that you can end up with a large memory, multi-CPU Sheevaplug (so make -j2, etc.), and can pause the while thing in mid kernel-build, switch everything off and then start again hours later, picking up in mid-compilation.

 72 
 on: September 25, 2013, 11:31:40 AM 
Started by cbxbiker61 - Last post by cbxbiker61
Yeah, you will be fine skipping that patch for kernel builds.

And yes, you must populate that armv* directory with "certain" files from your target machine's /usr/lib or /lib and /usr/include.  For the most part they really don't come into play with a kernel build, but some of the build process expects to find them.

 73 
 on: September 25, 2013, 03:54:26 AM 
Started by kemrit - Last post by kemrit
So i have had a try with the internal microSD (2GB /dev/sda). It is working - Debian is booting now from /dev/sda... But i prefer to use the SD Card (16GB /dev/sdb). Does anybody know how to accomplish that?

Thanks in advance

kemrit


 74 
 on: September 25, 2013, 12:32:11 AM 
Started by cbxbiker61 - Last post by pqa
cbxbiker, birdman, many thanks for the cross-compile info.

At the moment I'm going to go with trying to build a toolchain.

Cbxbiker - I have found a couple of problems with running the script:
1) http://www.xilka.com/xilka/source/patches/Gcc-4.8.2-arm-thumb2-CASE_VECTOR_SHORTEN_MODE.patch does not exist in http://www.xilka.com/xilka/source/patches
2) I get "ERROR 502: Bat Gateway." when I try to download http://www.xilka.com/xilka/source/patches/BinUtils-2.23.2-Add-supports-of-the-Marvell-PJ4-core.patch

Since the above patches don't look armv5te related, I have continued without them.

I found the following patch is also needed, to allow binutils to compile:
https://sourceware.org/cgi-bin/cvsweb.cgi/src/bfd/doc/bfd.texinfo.diff?r1=1.18&r2=1.19&cvsroot=src

Finally, in section 034/059, there is a copy from ~/source/src/CrossArm/root/$Target/{lib,usr/lib,usr/include}/* into the $respin directory tree. I'm not clear what is copied, nor how the files there are constructed. For the time being, I have copied the whole of /lib, /usr/lib, /usr/include from the target system to ~/source/src/CrossArm/root/$Target/{lib,usr/lib,usr/include}, but that seems overkill, and may not be the right way to do it.

So, I now have a build toolchain, so I'll start trying to build some kernels, but it would be good to resolve the above points so I know I am building with something equivalent to what you are using.


 75 
 on: September 24, 2013, 11:30:22 PM 
Started by cbxbiker61 - Last post by marcus11
It's not happy on Debian 7 x64:

I added the missing patch, not a terribly important patch for compiling the kernel.


Code:
--2013-09-25 16:28:06--  http://www.xilka.com/xilka/source/patches/BinUtils-2.23.2-Add-supports-of-the-Marvell-PJ4-core.patch
Resolving www.xilka.com (www.xilka.com)... 108.62.185.77
Connecting to www.xilka.com (www.xilka.com)|108.62.185.77|:80... connected.
HTTP request sent, awaiting response... 502 Bad Gateway
2013-09-25 16:28:07 ERROR 502: Bad Gateway.

The server behind your nginx has fallen over now?
 Shocked

 76 
 on: September 24, 2013, 04:36:02 PM 
Started by cbxbiker61 - Last post by birdman
This page:(whcih is for a different hardware, but still a Kirkwood setup) metions:
Quote
To enable the serial console: (This is in addition to the 8250/16550 and serial console support you should generally have enabled for kirkwood.)

Device Drivers --> Character Devices --> Serial Drivers

    Serial port on Open Firmware platform bus (CONFIG_SERIAL_OF_PLATFORM)
but this isn't set on cbxbiker61's config.  Could this be the problem?

 77 
 on: September 24, 2013, 04:16:45 PM 
Started by cbxbiker61 - Last post by cbxbiker61
It's not happy on Debian 7 x64:

I added the missing patch, not a terribly important patch for compiling the kernel.

 78 
 on: September 24, 2013, 03:05:20 PM 
Started by kemrit - Last post by kemrit
Does anybody know how i can tweak the debian installer to install uImage to SDB2 instead of SDA2? Or how i could initiate this from the rescue console?

Thanks for any comments

kemrit

 79 
 on: September 24, 2013, 01:30:47 PM 
Started by kemrit - Last post by kemrit
I checked printenv and debian installation for both the SD card used for installation is listed in SDB. So SDA is obviously wrong. Does anybody know how i can fix this? Or does the debian installation only support the installation to the dreamplug microSD which would be SDA?

Thanks for any hints

kemrit

 80 
 on: September 24, 2013, 12:56:04 PM 
Started by PeniWize - Last post by kemrit
Hi,

my dreamplug is a 003-DS2001 and i dared to upgrade my self installed Debian System (http://blog.davideaves.com/archives/2011/03/21/installing_debian_gnulinux_6_0_1_squeeze_on_the_dreamplug/). As the uImage hasn't been upgraded as well the whole system wasn't useable anymore. I started from the beginning in order to have a debian system which generates uImage for itself --> Upgrades will be possible.

1. Upgrading uBoot worked, takes some time, uBoot start up configuration needs to be altered :               http://www.cyrius.com/debian/kirkwood/sheevaplug/uboot-upgrade/ 
2. Installing Debian still ongoing (posted here in the forum:        http://www.cyrius.com/debian/kirkwood/sheevaplug/install/

Question 1: I doubt that! Did you try the images of NewIT already? http://downloadsnewit.co.uk/SD-images/Dreamplug/NewIT-Dreamplug-v0901-v1001-multibootSD-Wheezy/

Question 2: The images of NewIT should work. Can't test myself asi don't want to touch uBoot script again ;-)  Still trying to install Debian Wheezy...

Hope that helps...

kemrit

Pages: 1 ... 6 7 [8] 9 10