• Home
  • Help
  • Search
  • Login
  • Register
Pages: 1 ... 3 4 [5] 6 7 ... 10
 41 
 on: November 25, 2013, 02:06:42 AM 
Started by ineiti - Last post by ineiti
Trying to revive this thorny subject... Here is what I tried:

- u-boot from u-boot_2013.10-2_armel.deb
- 3.12.1-version of the kernel from http://www.xilka.com/
- the latest version of the sd8787-firmware (md5sum: bda543cb5943eac34e16d12911f3ee99)
- the latest version of hostapd from git

But there is definitively something wrong, as I only get a "mlan0"-interface, and no "wlan0" or other.

If I use mlan0 in hostapd, I get the following error:

Configuration file: hostapd.conf
ieee80211 phy0: mlan0: changing to 3 not supported
ieee80211 phy0: mlan0: changing to 3 not supported
nl80211: Could not configure driver mode
nl80211 driver initialization failed.
hostapd_free_hapd_data: Interface mlan0 wasn't started

Any idea what I missed? It works fine in client-mode, but I'd prefer AP Wink

 42 
 on: November 23, 2013, 01:54:43 PM 
Started by debio - Last post by ineiti
Hi,

I'm trying to use my Dreamplug as AP. It's a 1001-model, with a SD8787. I downloaded the kernel 3.12.1 from 'xilka.com' and even got a new uInitrd going. I also downloaded the file sd8787_uapsta.bin and put it in /lib/firmware/mrvl.

I get the card to run in client mode, but I never see a uap0 device, only mlan0. What else must I do to be able to use the wifi as AP?

 43 
 on: November 18, 2013, 03:45:19 PM 
Started by littlebigman - Last post by littlebigman
In case someone else has the same problem, reinstalling Debian on an SD card solved the issue:
http://www.cyrius.com/debian/kirkwood/sheevaplug/install/

 44 
 on: November 07, 2013, 08:26:17 AM 
Started by littlebigman - Last post by littlebigman
Hello

After replacing the blown PSU with a new one from NewIT, the Debian6 that I use to upgrade from the original Ubuntu 9.04 no longer boots.

I'm no Linux expert, and have no idea what to try.

Thanks for any help.

Here's the output from the micro-USB port as seen by Putty in Windows:
Code:
Marvell>> reset
resetting ...


U-Boot 2011.12 (Mar 11 2012 - 18:59:46)
Marvell-Sheevaplug - eSATA - SD/MMC

SoC:   Kirkwood 88F6281_A0
DRAM:  512 MiB
WARNING: Caches not enabled
NAND:  512 MiB
In:    serial
Out:   serial
Err:   serial
Net:   egiga0
88E1116 Initialized on egiga0
Hit any key to stop autoboot:  0
Marvell>> boot
Creating 1 MTD partitions on "nand0":
0x000000500000-0x000020000000 : "mtd=2"
UBI: attaching mtd1 to ubi0
UBI: physical eraseblock size:   131072 bytes (128 KiB)
UBI: logical eraseblock size:    129024 bytes
UBI: smallest flash I/O unit:    2048
UBI: sub-page size:              512
UBI: VID header offset:          512 (aligned 512)
UBI: data offset:                2048
UBI: attached mtd1 to ubi0
UBI: MTD device name:            "mtd=2"
UBI: MTD device size:            507 MiB
UBI: number of good PEBs:        4056
UBI: number of bad PEBs:         0
UBI: max. allowed volumes:       128
UBI: wear-leveling threshold:    4096
UBI: number of internal volumes: 1
UBI: number of user volumes:     1
UBI: available PEBs:             0
UBI: total number of reserved PEBs: 4056
UBI: number of PEBs reserved for bad PEB handling: 40
UBI: max/mean erase counter: 23/4
UBIFS: recovery needed
UBIFS error (pid 0): ubifs_recover_leb: LEB 24 scanning failed
Error reading superblock on volume 'ubi:rootfs'!
UBIFS not mounted, use ubifs mount to mount volume first!
UBIFS not mounted, use ubifs mount to mount volume first!
Wrong Image Format for bootm command
ERROR: can't get kernel image!
Marvell>>
Marvell>> print
baudrate=115200
bootargs=console=ttyS0,115200 ubi.mtd=2 root=ubi0:rootfs rootfstype=ubifs
bootargs_ubi=console=ttyS0,115200 ubi.mtd=2 root=ubi0:rootfs rootfstype=ubifs
bootcmd=setenv bootargs $(bootargs_ubi); run bootcmd_ubi; bootm 0x00800000 0x01100000
bootcmd_ubi=ubi part nand0,2; ubifsmount rootfs; ubifsload 0x1100000 /boot/uInitrd; ubifsload 0x800000 /boot/uImage
bootdelay=3
ethact=egiga0
ethaddr=00:50:43:01:69:B7
mtddevname=u-boot
mtddevnum=0
mtdids=nand0=orion_nand
mtdparts=mtdparts=orion_nand:0xa0000@0x0(u-boot),0x400000@0x100000(uImage),0x1fb00000@0x500000(rootfs)
partition=nand0,0
stderr=serial
stdin=serial
stdout=serial
x_bootargs=console=ttyS0,115200 mtdparts=orion_nand:512k(uboot),4m@1m(kernel),507m@5m(rootfs) rw
x_bootargs_root=ubi.mtd=2 root=ubi0:rootfs rootfstype=ubifs
x_bootcmd_kernel=nand read 0x6400000 0x100000 0x400000
x_bootcmd_sata=ide reset;
x_bootcmd_usb=usb start;

Environment size: 944/131068 bytes
Marvell>>

 45 
 on: November 02, 2013, 04:56:37 PM 
Started by felipito - Last post by felipito
Hi all,

I have here a Guruplug that doesn't boot any more. With the help of the JTAG-debugger, I have figured out that the processor doesn't jump to the U-Boot start address 0x00600000. Furthermore, it remains in an endless loop at address 0xffff0b2e:

Code:
> halt
target state: halted
target halted in Thumb state due to debug-request, current mode: Supervisor
cpsr: 0x400000f3 pc: 0xffff0b2e

But when I load the U-Boot over an OpenOCD-session and execute 'resume 0x00600000', the bootloader starts as expected. Now, my question: does somebody knows how to solve this problem? Thanks in advance.

Regards,

Luis

 46 
 on: October 26, 2013, 10:16:38 AM 
Started by recursix - Last post by littlebigman
I went through the threads on the subject, and since it requires some knowledge of electronics, which I don't have, I just ordered a new PSU from NewIt, although 10 + 10 is a bit high if it just means replacing one or two caps :-/

 47 
 on: October 26, 2013, 03:57:22 AM 
Started by recursix - Last post by littlebigman
Thanks for the infos. I attached a picture of my dead SP.

Is there a precise, newbie-accessible HOWTO on what component to order and how to perform the operation, including how to use a multimeter?

 48 
 on: October 19, 2013, 04:23:14 PM 
Started by cbxbiker61 - Last post by marcus11
Updated u-boot 2013.10 final attached, flash like so:
copy to fat16 usb stick
in existing console:
usb start
fatload usb 0 0x800000 u-boot.kwb
nand erase 0x0 0x80000
nand write 0x0800000 0x0 0x80000

Build instructions and patches for the built binary from https://doukki.net/doku.php?id=wiki:tutoriels:uboot.howto
Code:
Marvell>> version

U-Boot 2013.10 (Oct 20 2013 - 09:13:23)
Marvell-Sheevaplug - eSATA - SD/MMC
arm-none-linux-gnueabi-gcc (GCC) 4.2.1
GNU ld (GNU Binutils) 2.18.50.20070820

Note you'll want to set the nand sizes differently to the default if you wish to access it via linux.  Here's my env that handles the debian stock and cbxbiker kernels without modification from SD:
Code:
baudrate=115200
bootargs=console=ttyS0,115200n8 earlyprintk mtdparts=orion_nand:512k(uboot),128k(uboot_env),11m@1m(kernel),-@12m(rootfs) root=/dev/mmcblk0p2 rootdelay=5
bootcmd=run x_bootcmd; run z_bootstrap; reset;
bootdelay=3
console=console=ttyS0,115200n8
ethact=egiga0
ethaddr=00:50:43:01:D0:7B
filesize=6da04
initrdaddr=0x01100000
initrdfile=/uInitrd
kerneladdr=0x00800000
kernelfile=/uImage
loadcmd=ext2load mmc 0:1
mtdids=nand0=orion_nand
mtdparts=mtdparts=orion_nand:512k(uboot),128k(uboot_env),11m@1m(kernel),-@12m(rootfs)
scriptaddr=0x00800000
scriptfile=/boot/boot.scr
stderr=serial
stdin=serial
stdout=serial
x_bootargs=console=ttyS0,115200n8 earlyprintk mtdparts=orion_nand:512k(uboot),128k(uboot_env),11m@1m(kernel),-@12m(rootfs)
x_bootargs_root=root=/dev/mmcblk0p2 rootdelay=5
x_bootcmd=${x_bootcmd_kernel}; setenv bootargs ${x_bootargs} ${x_bootargs_root}; run z_bootinit;
x_bootcmd_kernel=echo ====== BootStrap start ======
x_bootcmd_mtd=nand read.e ${kerneladdr} kernel 0x00b00000;
x_bootstrap_cmd=for device in "mmc"; do for fs in "ext2"; do setenv loadcmd "${fs}load ${device} 0:1"; if ${loadcmd} ${kerneladdr} ${kernelfile}; then; if ${loadcmd} ${initrdaddr} ${initrdfile}; then; run z_bootcmd; fi; fi; done; done;
z_bootcmd=if imi ${kerneladdr}; then; bootm ${kerneladdr} ${initrdaddr}; else; echo --- next bootcmd device try ---; fi;
z_bootfail=echo ====== BootStrap end ======
z_bootinit=mmc rescan; usb reset; ide reset;
z_bootstrap=run z_bootinit; run x_bootstrap_scr; run x_bootstrap_cmd; run x_bootcmd_mtd; run z_bootfail;

Environment size: 1612/131068 bytes

I've also compiled netconsole in (untested).

Stuff added to include/configs/sheevaplug.h:
Code:
#define CONFIG_OF_LIBFDT
#define CONFIG_SYS_CONSOLE_IS_IN_ENV 1
#define CONFIG_CMD_NET
#define CONFIG_CMD_CONSOLE
#define CONFIG_CMD_DNS


 49 
 on: October 10, 2013, 03:36:50 AM 
Started by cbxbiker61 - Last post by Acid_Jack
it is very risky
i want to see all console output
so i better stay with previous kernel
kirkwood-* kernels boots without such problem (but lacks uap module)

i don't use 'machid'

 50 
 on: October 10, 2013, 03:31:51 AM 
Started by cbxbiker61 - Last post by apemberton
Although the console 'freezes' with Device Tree kernels earlier than 3.11.2 for Guruplug (I am running this on my Guruplugs) it is possible that you may get access using SSH after a period for the kernel to boot fully.

Another possibility is do you have a line 'machid=a63' in your u-boot environment? (Replaces arcNumber.)

Pages: 1 ... 3 4 [5] 6 7 ... 10