• Home
  • Help
  • Search
  • Login
  • Register
Pages: 1 2 [3] 4 5 ... 10
 on: February 19, 2014, 01:07:31 AM 
Started by cbxbiker61 - Last post by mgillespie
Working OK again today. Grabbed the last 3.11 kernel and will stick with that seems more robust on my sheevaplug.

 on: February 18, 2014, 07:43:31 PM 
Started by cbxbiker61 - Last post by birdman
Anyone else having problems with http://www.xilka.com ?
Not at the moment. I've just browsed down through the 3.13.3 kernel listing with no problem.
Quote from: see above
Many links just redirect to www.appfail.com  Huh
Odd place to go.  The xilka site isn't accessed over https.  Well, it can be, but the certificate is issued for "*.scaleengine.net", which is where xilka.com lives, but isn't of any use for it.
Seems odd to go to the expense of a valid wildcard certificate (from Comodo) when the subject name isn't actually going to be used.

 on: February 18, 2014, 04:14:02 PM 
Started by cbxbiker61 - Last post by mgillespie
Anyone else having problems with http://www.xilka.com ?

Many links just redirect to www.appfail.com  Huh

Has this site been compromised?  Have the kernels it hosts been compromised too?  All rather unnerving....

I desperately need to downgrade from 3.13.2 due to ehci usb disconnect problems, but can't get an old kernel, not do I trust that site anymore even if I could...

 on: February 08, 2014, 05:08:21 PM 
Started by NewIT - Last post by alexK
Has anyone successfully gotten the CuBox wifi to function as an access point?

 on: February 08, 2014, 05:03:39 PM 
Started by LavaChild - Last post by alexK
The OLPC XO Serial Adapter Kit $25
works on my DreamPlug at half the price.
The only proviso is that you must connect Black, Red, Green to Ground, Rx, Tx (respectively) rather than the way you would if you were connecting to an XO.
No soldering involved.  It comes with the correct connector.
It's very small and much more convenient than the expensive one provided by Globalscale.

You could also consider Adafruit's FTDI Friend:
but you'd have to also get the correct connector- one of the "picoblade" products from AMP.   
Available here:
But you'd have to figure out how to connect the wires- I haven't figured it out yet although haven't tried very hard because the XO adapter works very well.

 on: February 08, 2014, 04:45:28 PM 
Started by ineiti - Last post by alexK
I've been struggling with this problem as well.
I've got the following installed and working on my DreamPlug model: 003-DS2001:
wget http://http.debian.net/debian/pool/main/u/u-boot/u-boot_2012.04.01-2_armel.deb
wget http://http.debian.net/debian/dists/wheezy/main/installer-armel/current/images/kirkwood/netboot/marvell/dreamplug/uImage
wget http://http.debian.net/debian/dists/wheezy/main/installer-armel/current/images/kirkwood/netboot/marvell/dreamplug/uInitrd

It has the 8787 wifi chipset.

As suggested in a previous post, I tried:
root@shirati:/etc/apt# iw dev mlan0 interface add uap0 type __ap
command failed: No such device (-19)

but as you can see, I'm missing something.  The "__ap" looks suspicious.
I'd be grateful for any guidance.

 on: February 07, 2014, 08:16:50 PM 
Started by ineiti - Last post by debio
I went ahead and opened a kernel bug at https://bugzilla.kernel.org/show_bug.cgi?id=70191 to try to investigate the instabilities.

 on: February 07, 2014, 05:43:25 AM 
Started by ptosch - Last post by ptosch

Thanks bigbear59, that link was the hint I needed.

I fixed the lines to be able to boot from ubifs.

Assuming the partitions on NAND:
# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00100000 00020000 "u-boot"
mtd1: 00400000 00020000 "uImage"
mtd2: 1fb00000 00020000 "root"

And assuming partitions on sdcard:
# fdisk -l /dev/mmcblk0

/dev/mmcblk0p1   *        2048      499711      248832   83  Linux
/dev/mmcblk0p2          499712    30472191    14986240   83  Linux
/dev/mmcblk0p3        30472192    31291391      409600   82  Linux Swap / Solaris

for ubifs it shoud look like this:

setenv bootcmd_mmc 'mmc init; mmc init; ext2load mmc 0:1 0x00800000 /uImage; ext2load mmc 0:1 0x01100000 /uInitrd'
setenv bootargs_nand 'rootfstype=ubifs console=ttyS0,115200 mtdparts=orion_nand:0x400000@0x100000(uImage),0x1fb00000@0x500000(rootfs) ubi.mtd=1 root=ubi0:rootfs rw
setenv root '/dev/mtdblock1 rw ip=:'
setenv bootcmd_nand 'setenv bootargs $(bootargs_nand); nand read.e 0x800000 0x100000 0x400000; bootm 0x800000'
setenv bootcmd 'setenv bootargs $(bootargs_console); run bootcmd_mmc; bootm 0x00800000 0x01100000; run bootcmd_nand'

Now I have a fallback system if the SDCard shouldn't work.


 on: February 01, 2014, 09:38:58 PM 
Started by ineiti - Last post by debio
I emailed Linux-wireless, and apparently we're supposed to create the AP interface with a command like this: `iw dev mlan0 interface add uap0 type __ap`
This should eliminate the need for any kernel patches.

The next problem I'm having is that after running the access point for a while, the interfaces transmit queue hangs. With WPA, it tends to happen within a few seconds or minutes. With no encryption, it lasts longer, but eventually hangs after tens of minutes or an hour or two. Are you seeing something similar?

 on: January 31, 2014, 10:55:27 PM 
Started by ineiti - Last post by debio
Yes, AP mode works and I can connect. Throughput is pretty nice as well.

Then the card hung, the driver tried to reset it and failed to load the firmware after reset, and hostapd started panicking because the interface disappeared out from under it.

I'll see if I can tweak it at all.

Pages: 1 2 [3] 4 5 ... 10