• Home
  • Help
  • Search
  • Login
  • Register
Pages: 1 [2] 3 4 ... 10
 11 
 on: February 07, 2014, 05:43:25 AM 
Started by ptosch - Last post by ptosch

Thanks bigbear59, that link was the hint I needed.

I fixed the lines to be able to boot from ubifs.

Assuming the partitions on NAND:
Code:
# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00100000 00020000 "u-boot"
mtd1: 00400000 00020000 "uImage"
mtd2: 1fb00000 00020000 "root"

And assuming partitions on sdcard:
Code:
# fdisk -l /dev/mmcblk0

/dev/mmcblk0p1   *        2048      499711      248832   83  Linux
/dev/mmcblk0p2          499712    30472191    14986240   83  Linux
/dev/mmcblk0p3        30472192    31291391      409600   82  Linux Swap / Solaris


for ubifs it shoud look like this:

Code:
setenv bootcmd_mmc 'mmc init; mmc init; ext2load mmc 0:1 0x00800000 /uImage; ext2load mmc 0:1 0x01100000 /uInitrd'
setenv bootargs_nand 'rootfstype=ubifs console=ttyS0,115200 mtdparts=orion_nand:0x400000@0x100000(uImage),0x1fb00000@0x500000(rootfs) ubi.mtd=1 root=ubi0:rootfs rw
setenv root '/dev/mtdblock1 rw ip=:10.4.50.5:10.4.50.5:255.255.255.0:DB88FXX81:eth0:none'
setenv bootcmd_nand 'setenv bootargs $(bootargs_nand); nand read.e 0x800000 0x100000 0x400000; bootm 0x800000'
setenv bootcmd 'setenv bootargs $(bootargs_console); run bootcmd_mmc; bootm 0x00800000 0x01100000; run bootcmd_nand'
saveenv


Now I have a fallback system if the SDCard shouldn't work.

Regards,
 Peter

 12 
 on: February 01, 2014, 09:38:58 PM 
Started by ineiti - Last post by debio
I emailed Linux-wireless, and apparently we're supposed to create the AP interface with a command like this: `iw dev mlan0 interface add uap0 type __ap`
This should eliminate the need for any kernel patches.

The next problem I'm having is that after running the access point for a while, the interfaces transmit queue hangs. With WPA, it tends to happen within a few seconds or minutes. With no encryption, it lasts longer, but eventually hangs after tens of minutes or an hour or two. Are you seeing something similar?

 13 
 on: January 31, 2014, 10:55:27 PM 
Started by ineiti - Last post by debio
Yes, AP mode works and I can connect. Throughput is pretty nice as well.

Then the card hung, the driver tried to reset it and failed to load the firmware after reset, and hostapd started panicking because the interface disappeared out from under it.

I'll see if I can tweak it at all.

 14 
 on: January 31, 2014, 10:34:34 PM 
Started by ineiti - Last post by debio
I just reversed that commit and built a kernel image, and it looks like I have AP mode. Hostapd starts up on uap0. I'll have to test it to see if it's actually stable.

I guess the next step is probably to email Linux-wireless to complain that the mwifiex driver doesn't support changing an interface from managed mode to AP mode, but the iw utilities don't provide a way to create an AP mode interface.


 15 
 on: January 31, 2014, 09:54:54 PM 
Started by ineiti - Last post by debio
I think our biggest source of problems is this:
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/drivers/net/wireless/mwifiex?id=1211c961170cedb21c30d5bb7e2033c8720b38db

This was the commit that disabled the creation of the uap0 and ptp0 interfaces. The commit description claims these interfaces can be created manually through `iw`, but I haven't figured out how to create an AP mode interface.

 16 
 on: January 31, 2014, 01:02:51 PM 
Started by ptosch - Last post by bigbear59
Take a look here,
Yet another sheevaplug dual boot question <-- Click here
Hopefully it will answer your questions.

Ask back here for any clarification.



 17 
 on: January 31, 2014, 12:53:04 PM 
Started by ptosch - Last post by odoll
Yes, you have to configure uboot accordingly. You will have to search and read sone the older threads

 18 
 on: January 27, 2014, 09:12:30 AM 
Started by ptosch - Last post by ptosch
Hello,

I have a sheevaplug with an ubuntu installed on NAND (ubifs). Now I would like to Install debian on Sdcard.

Is it possible to boot from sdcard as long as an sdcard is plugged in but when it is removed, it should boot from NAND ?

Somehow like my dockstar: it is always booting from usb.stick, but when the stick is not inserted, it boots from its internal image.

Regards,
 Peter

 19 
 on: January 26, 2014, 07:31:07 PM 
Started by bad_gui - Last post by birdman
Then I used dd to copy the contents of the partitions to the new drive.
So you copied the file system (which includes its size) into what is now a larger partition.  But the file-system is still the same size.

You need to use resize2fs to expand the file-system on /dev/sda9 now (assuming it is an ext2/ext3/et4 file-system).

Take a look at it's man page, and:

   http://webapp5.rrz.uni-hamburg.de/SuSe-Dokumentation/manual/sles-manuals_en/manual/biuymaa.html

NOTE that you have already enlarged the partition - you just want to grow the file-system to use all of the space.

Also note that all of these things warn about backing up before you do anything.

 20 
 on: January 26, 2014, 08:44:01 AM 
Started by bad_gui - Last post by bad_gui
I have Guruplug server booting from an external SATA drive.

A while ago I upgraded the drive from 1TB to 2TB by transferring both drives to a desktop computer.  First
I created a new partition table on the 2TB drive with everything the same except /dev/sda9 which I set to
use the ending cylinder.  Then I used dd to copy the contents of the partitions to the new drive.

Wheezy boots from the new drive and everything seems OK except when I use df -h I see that /dev/sda9
is much smaller than it is supposed to be:

Code:
# df -H
Filesystem                                              Size  Used Avail Use% Mounted on
rootfs                                                  272M  153M  105M  60% /
udev                                                     11M     0   11M   0% /dev
tmpfs                                                    53M  476k   53M   1% /run
/dev/disk/by-uuid/525184d1-eb77     272M  153M  105M  60% /
tmpfs                                                   5.3M     0  5.3M   0% /run/lock
tmpfs                                                   415M     0  415M   0% /run/shm
/dev/sda1                                               239M   39M  188M  17% /boot
/dev/sda9                                               975G   34G  892G   4% /home
/dev/sda8                                               386M   11M  356M   3% /tmp
/dev/sda5                                               5.0G  1.2G  3.6G  24% /usr
/dev/sda6                                               3.0G  652M  2.2G  24% /var


But /dev/sda9 should have an extra 1TB according to this

Code:
# sfdisk -l -uM
Disk /dev/sda: 243201 cylinders, 255 heads, 63 sectors/track
Warning: extended partition does not start at a cylinder boundary.
DOS and Linux will interpret the contents differently.
Units = mebibytes of 1048576 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start   End    MiB    #blocks   Id  System
/dev/sda1   *     1    243    243     248832   83  Linux
/dev/sda2       244    510    267     273408   83  Linux
/dev/sda3       511  1907728  1907218  1952991232    5  Extended
/dev/sda4         0      -      0          0    0  Empty
/dev/sda5       512   5283   4772    4886528   83  Linux
/dev/sda6      5285   8141   2857    2925568   83  Linux
/dev/sda7      8143   9617   1475    1510400   82  Linux swap / Solaris
/dev/sda8      9619   9998    380     389120   83  Linux
/dev/sda9     10000  1907728  1897729  1943274496   83  Linux


Am I understanding this correctly?  The /dev/sda9 partition is the correct size but the
filesystem can't see the extra 1 TB?

The other problem I had was that the swap partition kept the UUID of the old drive rather
than the new drive.  I had all kinds of weird memory problems until I saw the error in
/etc/fstab.

Pages: 1 [2] 3 4 ... 10