• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1] 2 3 ... 10
 on: March 25, 2015, 08:07:24 AM 
Started by rnsi - Last post by littlebigman
Thanks for the info.

Browing http://globalscaletechnologies.com/download/ shows that Sheeva-Debian7-SW.rar is 360.838.856 bytes while sheevaplug_env.tar.rar is 226.624.239 bytes: Will both fit into the Sheevaplug's 512MB NAND, or should some of it be moved to an SD card?

 on: February 16, 2015, 07:03:32 AM 
Started by rnsi - Last post by rnsi
Globalscale has released a new Sheevaplug reflash guide:


I've used this to reflash several older Sheevaplugs, and it works well after some changes. The filesystem image provided (rootfs.tar.gz) does not have /dev/console, /dev/null or /dev mtd*. Create these first and the reflash works perfectly. This will install Debain (Kernel 3.13.10) to NAND to replace Ubuntu 9.0.4. If you have bad NAND blocks you can boot and use nandtest to mark them as bad before proceeding. I did not need to upgrade uBoot for this to work, just resetenv.

 on: January 29, 2015, 09:04:50 AM 
Started by biertrnker - Last post by biertrnker
just for information, i managed to the kernel boot right by setting bootargs root=UUID=0b779512-624b-44c2-b460-5ac202fXXXX.

I can't get it to boot with dev/sdX but with the Partitions UUID its ok.



 on: January 28, 2015, 05:06:48 AM 
Started by biertrnker - Last post by biertrnker
I tried a bit more, the module sata_mv is included in the initrd i can load it with modprobe:

[    2.015879] dracut: dracut-7 (wheezy) dracut-
[    2.049946] dracut: FATAL: No or empty root= argument
[    2.055087] dracut: Refusing to continue
[    2.059532] dracut Warning:
[    2.063126] dracut Warning: dracut: FATAL: No or empty root= argument
[    2.070758] dracut Warning: dracut: Refusing to continue
[   11.975272] SCSI subsystem initialized
[   11.985942] libata version 3.00 loaded.
[   11.988103] sata_mv f1080000.sata: version 1.28
[   11.988258] sata_mv f1080000.sata: slots 32 ports 1
[   11.995207] scsi0 : sata_mv
[   11.998376] ata1: SATA max UDMA/133 irq 21
[   17.516993] ata1: link is slow to respond, please be patient (ready=0)
[   18.417006] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl F300)
[   18.445092] ata1.00: ATA-8: JMB352  RAID-1, , max UDMA/133
[   18.450622] ata1.00: 3907029152 sectors, multi 0: LBA48
[   18.501084] ata1.00: configured for UDMA/133
[   18.505771] scsi 0:0:0:0: Direct-Access     ATA      JMB352  RAID-1   n/a  PQ: 0 ANSI: 5

but i don't now why it is not loaded automaticaly? Im not shure, is this "device tree" think the reason, or is the "dracut" software building the initrd the problem?

 on: January 28, 2015, 04:12:42 AM 
Started by biertrnker - Last post by biertrnker

i can't get a recent debian kernel to boot on my guruplug server+, so i hope you could help me out. I am running a Debian System on the guru with a ESATA Raid connected where the root filesystem is on. With the old 3.2.35 kernel i installed under squeeze the system boots up as expected. Now i have updated to wheezy and tried to install a brand ne kernel 3.16.0 from backports. At first nothing happend after uBoot. I had to update the uboot to an FDT enabled Vesion (2014.01) and appended a dtb file from http://xilka.com/ to the kernel image. After that i can see the kernel booting - but after a few seconds i get a few error messages and a debug shell:

[   31.489735] dracut Warning: Could not boot.
dracut Warning: [   31.494718] dracut Warning: "/dev/sdc2" does not exist
Could not boot.
dracut Warning: "/dev/sdc2" does not exist

Dropping to debug shell.

at first the message was a liddle bit different, something like "dracut Warning: root attribute not set", changed to >> "/dev/sdc2" does not exist<< when i set root=/dev/sdc2.

In the debug-shell there is no device /dev/sdc* - so i assume that the module for the esata port ist not loaded?

i don't know what to do next?

thanks in advance



 on: December 09, 2014, 02:02:04 PM 
Started by Raśl Porcel - Last post by ulrith
I've just happy upgraded my SheevaPlag eSATA to fresh Debian 7 with this brilliant manuals:



Everything are clear and smooth.

 on: August 31, 2014, 08:53:02 AM 
Started by restamp - Last post by nhoeller
@birdman, I had a chance to play around with the various INIT options.  The following has worked so far for me in terms of running wait4usbdisks until just before checkfs.sh but also ensuring that checkfs.sh does not start before wait4usbdisks has finished.

# Provides:          wait4usbdisks
# Required-Start:    checkroot
# Required-Stop:
# Should-Start:
# Should-stop:
# Default-Start:     S
# Default-Stop:
# X-Interactive:     true
# X-Start-Before:    checkfs
# X-Stop-After:
# Short-Description: Delays boot to ensure USB disks are connected.

I also removed the "exit 1" from the "start)" logic to prevent errors being posted after wait4usbdisks had finished. 

 on: August 11, 2014, 02:23:52 PM 
Started by mgillespie - Last post by mhtsaras
I have the plug for some years now, booting from sd card debian wheezy, i have some old sd rootfs.tar.gz back ups that can extract to sd card if something is wrong.
I tried to get a fresh new copy and formated a partition on sd card, created inside the rootfs.tar.gz   with DebianSheeva1-7.sh script, copy to a usb disk attached with plug and extract it from the usb disk to the sd partition
I reboot and I try to connect with putty (from another lan computer) get the login screen and type  user: root   password:nosoup4u , I get "acess denied"
I reset the password from shadow file reboot--user:root-password:<enter>--"acess denied"
Can rootfs.tar.gz be used like this, meaning , extract and get it work;; or I am doing something wrong?
I also can boot form plug's internal memory if I pull the sd card and reboot so I do some stuff but not get the generated rootfs from your script....
Thanx in advance!

 on: August 07, 2014, 05:40:19 PM 
Started by restamp - Last post by birdman
Does your copy include the debian headers, as given by mgillespie in: http://www.plugcomputer.org/plugforum/index.php?topic=485.0#msg5425
Mind you, on looking at that more closely it appears to be wrong.  The
Required-Start; checkfs
part means that it will run after checkfs, but I suspect you need it to run before checkfs.

To do that you can leave the
in wait4usbdisks empty, (i.e. you'll need to edit it to remove the checkfs that is there) but add wait4usbdisks to that line in the checkfs.sh script (after checkroot - with a space in between them).

Then run
update-rc.d wait4usbdisks defaults

 on: August 07, 2014, 05:29:03 PM 
Started by restamp - Last post by birdman
he right solution would be to have wait4usbdisks finish before checkfs.sh starts, without having to modify 'stock' initialization scripts. 
AFAIK wait4usbdisks is not a "stock" initialization script.  Indeed - it seems to have been posted in the first entry in this thread.

Does your copy include the debian headers, as given by mgillespie in: http://www.plugcomputer.org/plugforum/index.php?topic=485.0#msg5425

Have you made it executable?

Have you ensured that it gets run at the right time by running
update-rc.d wait4usbdisks defaults

Have you considered using a rootdelay in the boot environment settings?  I only have /boot on an SDcard, with everything else (including /) on a USB drive (which is running through a hub) so I must have the USB drive up, running and available before I can even boot.  It's always worked well.

Pages: [1] 2 3 ... 10