• Home
  • Help
  • Search
  • Login
  • Register
Pages: [1] 2 3 ... 10
 on: February 24, 2016, 12:46:45 PM 
Started by mossroy - Last post by mossroy
It might be because I did not apply any patch on the mainline kernel (except to disable highspeed on sd cards)?
I see a lot of patches in http://xilka.com/xilka/source/patches/ , but I don't know if some of them need to be applied

 on: February 24, 2016, 08:52:21 AM 
Started by mossroy - Last post by mossroy
A few years ago, I was compiling the kernel myself (using the .config files from www.xilka.com) to have a stable sheevaplug.
It is necessary because one my sheevaplugs does not seem to support highspeed SD cards (see http://www.plugcomputer.org/plugforum/index.php?topic=352.0 . It was one of the very first models of sheevaplug)

I worked well until kernel 3.8. But, since version 3.9, the kernels I compile do not start any more on my sheevaplugs.
They just freeze after "Starting kernel...".

Example (with kernel 4.4.2) :
U-Boot 2014.10+dfsg1-5 (Apr 07 2015 - 21:57:04)

SoC:   Kirkwood 88F6281_A1
DRAM:  512 MiB
WARNING: Caches not enabled
NAND:  512 MiB
In:    serial
Out:   serial
Err:   serial
Net:   egiga0
88E1116 Initialized on egiga0
Warning: Your board does not use generic board. Please read
doc/README.generic-board and take action. Boards not
upgraded by the late 2014 may break or be removed.
Hit any key to stop autoboot:  0
2906872 bytes read in 2209 ms (1.3 MiB/s)
10005495 bytes read in 2601 ms (3.7 MiB/s)
## Booting kernel from Legacy Image at 00800000 ...
   Image Name:   Linux-4.4.2
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    2906808 Bytes = 2.8 MiB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
## Loading init Ramdisk from Legacy Image at 01100000 ...
   Image Name:   ramdisk 3.16.0-4-kirkwood
   Image Type:   ARM Linux RAMDisk Image (uncompressed)
   Data Size:    10005431 Bytes = 9.5 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK

Starting kernel ...

I upgraded u-boot (from 2011.03 to 2014.10), but it did not help.

Here is how I compile :
- I take the source from kernel.org, and the .config from xilka.com (for the same kernel version)
- I compile with this command :
make -j4 ARCH=arm CROSS_COMPILE=../arm-2009q3/bin/arm-none-eabi- LOADADDR=0x00008000 uImage
- then I transfer the uImage file on the boot partition of my SD card (where I initially installed the same version of the kernel from xilka.com, that was starting correctly)

I've tried with other versions of the cross-compiler with no succsess (2008q3, and the ones from standard repos of Ubuntu 15.04 and 15.10)
I managed to make kernel 3.9 boot by modifying the .config (adding CONFIG_MACH_SHEEVAPLUG=y). But this config does not exist any more in 4.4.2

Here are my env variables in u-boot :
Marvell>> printenv
bootargs=console=ttyS0,115200 earlyprintk root=/dev/mmcblk0p2 rootwait panic=10
bootcmd=setenv bootargs $(bootargs_console); run bootcmd_mmc; bootm 0x00800000 0x01100000
bootcmd_mmc=ext2load mmc 0:1 0x00800000 /uImage; ext2load mmc 0:1 0x01100000 /uInitrd
x_bootargs=console=ttyS0,115200 mtdparts=mtdparts=orion_nand:512K(uboot),512K(env),1M(script),6M(kernel),12M(ramdisk),4M(spare),-(rootfs)x_bootcmd_kernel=nand read 0x6400000 0x100000 0x300000
x_bootargs_root=root=/dev/mtdblock3 rw rootfstype=jffs2
x_bootcmd_usb=usb start

Environment size: 720/131068 bytes
(only modified the ethaddr)

I read on http://www.plugcomputer.org/plugforum/index.php?topic=6255.0 that many changes have been made on the build/install process on xilka.com between 3.8 and 3.9 : it might be a side-effect?
In any case, the uImage files from xilka work fine, so there must be a way to make mine work (I just need to add the patch to disable highspeed on sd cards)

Any help/hint would be appreciated.


 on: November 08, 2015, 06:24:01 AM 
Started by Scotty - Last post by Scotty
My solution was to download all kirkwood stuff (e.g. from the ALARM home page) and extract it to an usb stick formatted with etx2. Before booting the boot parameters need some adjustment

setenv bootargs_root ubi.mtd=1 root=/dev/sda1 rootdelay=10

which makes the Sheeva boot from the usb stick. And after "mount /dev/ubi0.. /mnt" the world keeps revolving.

 on: November 07, 2015, 05:20:10 PM 
Started by Scotty - Last post by Scotty
I bricked my SheevaPlug by deleting the wrong file, i.e. /lib/ld-linux.3.so instead of /lib/ld-linux.2.so which I created before. The boot process hangs now, and I have no access to the file system. What can I do to fix this problem?

I'm running Arch Linux.

 on: April 23, 2015, 05:49:28 PM 
Started by rnsi - Last post by rnsi
It will fit, but you're probably much better off running the OS from SD. There's a HUGE difference in performance, and you don't need to worry about wearing out your NAND.

 on: March 31, 2015, 09:33:02 AM 
Started by phunksta - Last post by phunksta

I have successfully set up a link to my guruplug from a macbook pro using a USB-Serial adaptor, with a 3.3V setting.

I have GND--GND, TX--RX, RX--TX connected. I have double checked the connections for continuity as far as I can i.e. that my micro connector has continuity with where the cable plugs into the header of the adaptor (it is an exposed PCB type).

On booting the plug, the boot sequence is received into the terminal program all OK.

I cannot however transmit anything to the plug; it does not receive anything when keys are pressed to interrupt the boot. Once booted, and the message that the network adaptor has started, the login prompt is not appearing.

Am i missing something obvious, or is my serial comms broken somehow? I have heard a lot of these serial cables are counterfeit?

 on: March 25, 2015, 08:07:24 AM 
Started by rnsi - Last post by littlebigman
Thanks for the info.

Browing http://globalscaletechnologies.com/download/ shows that Sheeva-Debian7-SW.rar is 360.838.856 bytes while sheevaplug_env.tar.rar is 226.624.239 bytes: Will both fit into the Sheevaplug's 512MB NAND, or should some of it be moved to an SD card?

 on: February 16, 2015, 07:03:32 AM 
Started by rnsi - Last post by rnsi
Globalscale has released a new Sheevaplug reflash guide:


I've used this to reflash several older Sheevaplugs, and it works well after some changes. The filesystem image provided (rootfs.tar.gz) does not have /dev/console, /dev/null or /dev mtd*. Create these first and the reflash works perfectly. This will install Debain (Kernel 3.13.10) to NAND to replace Ubuntu 9.0.4. If you have bad NAND blocks you can boot and use nandtest to mark them as bad before proceeding. I did not need to upgrade uBoot for this to work, just resetenv.

 on: January 29, 2015, 09:04:50 AM 
Started by biertrnker - Last post by biertrnker
just for information, i managed to the kernel boot right by setting bootargs root=UUID=0b779512-624b-44c2-b460-5ac202fXXXX.

I can't get it to boot with dev/sdX but with the Partitions UUID its ok.



 on: January 28, 2015, 05:06:48 AM 
Started by biertrnker - Last post by biertrnker
I tried a bit more, the module sata_mv is included in the initrd i can load it with modprobe:

[    2.015879] dracut: dracut-7 (wheezy) dracut-
[    2.049946] dracut: FATAL: No or empty root= argument
[    2.055087] dracut: Refusing to continue
[    2.059532] dracut Warning:
[    2.063126] dracut Warning: dracut: FATAL: No or empty root= argument
[    2.070758] dracut Warning: dracut: Refusing to continue
[   11.975272] SCSI subsystem initialized
[   11.985942] libata version 3.00 loaded.
[   11.988103] sata_mv f1080000.sata: version 1.28
[   11.988258] sata_mv f1080000.sata: slots 32 ports 1
[   11.995207] scsi0 : sata_mv
[   11.998376] ata1: SATA max UDMA/133 irq 21
[   17.516993] ata1: link is slow to respond, please be patient (ready=0)
[   18.417006] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl F300)
[   18.445092] ata1.00: ATA-8: JMB352  RAID-1, , max UDMA/133
[   18.450622] ata1.00: 3907029152 sectors, multi 0: LBA48
[   18.501084] ata1.00: configured for UDMA/133
[   18.505771] scsi 0:0:0:0: Direct-Access     ATA      JMB352  RAID-1   n/a  PQ: 0 ANSI: 5

but i don't now why it is not loaded automaticaly? Im not shure, is this "device tree" think the reason, or is the "dracut" software building the initrd the problem?

Pages: [1] 2 3 ... 10