• Home
  • Help
  • Search
  • Login
  • Register
  Show Posts
Pages: [1]
1  Linux Stuff / Kernel / Re: 2.6.31 new release on: September 25, 2009, 03:44:20 AM
Hi cbxbiker61,

Just a quick note to say 'Sir, you are a star!!'.

Your latest pre-built kernel fixed my 'tun' issue with the standard install.

Fantastic!

Thanks,

Richard
2  Linux Stuff / General Linux questions / Re: OPenVPN and tun adapter - tun is missing?? FIXED on: September 25, 2009, 03:41:30 AM
Guys,

This is now fixed.

A HUGE thank you to: cbxbiker61 and Adam Franco for their pre-built kernels and instructions on how to install them.

The latest 2.6.31 prebuilt kernel has tun support included - OpenVPN now works a treat.

I used the following Wiki page for instructions:

http://www.openplug.org/plugwiki/index.php/Install_Prebuilt_Kernels_From_sheeva.with-linux.com

The only part missing is when running the README.... file, I installed to nand.

The hardest part was getting my MacBook Pro connecting to the SheevaPlug via the USB console!!

Again - HUGE thanks to these guys.  I can now retire my old XP laptop/server and keep the wife happy with my small, low power SheevaPlug providing all the same services (file share, imap/smtp, OpenVPN, squid)

Cheers, Richard
3  Linux Stuff / General Linux questions / Re: OPenVPN and tun adapter - tun is missing?? on: September 24, 2009, 02:19:41 AM
Thanks for the PPTP tip.  Unfortunately it's not really suitable for me as I need an SSL based VPN to work through our corporate proxy servers.

Are there alternatives to OPenVPN - I've been running OpenVPN as a server on Windows XP for a while (with Mac and PC clients) and it's fantastic!

I'm wondering if I can replace the kernel with a pre-compiled version (2.6.31?) - I see it has module support for tun adapters, but not sure if I then just run a modprobe tun and whether that will work.

Cheers, Richard

4  Linux Stuff / General Linux questions / OPenVPN and tun adapter - tun is missing?? on: September 22, 2009, 05:52:48 AM
Hi All,

received my SheevaPlug development kit last week.  Have now configured with webmin, squid, samba and dovecot, but when I try to configure with OpenVPN I have 'tun' adapter driver errors.

kernel is 2.6.22.18

When I 'modprobe tun' I get a FATAL error, 'module tun not found'.  So OPenVPN moans and I can't start it up (routed or bridged mode).

I'm ok with navigating linux, but have never compiled a kernel.  Is it just a matter of loading the driver (sorry, simplistic Windows approach...)

Thanks all,

Richard
Pages: [1]