• Home
  • Help
  • Search
  • Login
  • Register
  Show Posts
Pages: 1 [2]
16  General Category / General Discussion / Re: Setting up sheevaplug with wlan on: August 20, 2009, 01:59:24 PM
Huh Unfortunatly it didn't seem to work. I could connect and update using apt-get, and I didn't have any problems re-logging in. However, /lib/modules still remains empty x.x . Kernel version is 2.6.22.18 .

ljones
17  General Category / General Discussion / Re: Setting up sheevaplug with wlan on: August 20, 2009, 12:02:19 PM
Did you try upgrading the SheevaPlug? Isn't 2.6.22.18 the standard kernel?

Nope not upgraded it. Should I try the alpha-6 software first?

ljones/SP
18  General Category / General Discussion / Re: Setting up sheevaplug with wlan on: August 20, 2009, 11:22:37 AM
Since I did this yesterday...

1. Get a USB Wifi dongle  (something with a rtl8187 chipset would be good).
2. apt-get install wireless-tools
3. edit /etc/network/interfaces and add something like:

auto wlan0
iface wlan0 inet static
  address 192.168.1.51
  netmask 255.255.255.0
  broadcast 192.168.1.255
  gateway 192.168.1.1
  wireless-essid <your-network-SSID.
  wireless-key restricted 1 <your-WEP-key>
  wireless-defaultkey 1
#  wireless-mode Managed
  wireless-channel auto


If you are using WPA rather than WEP you'll have to do something different - perhaps someone else has done that?

:-( Unfortunatly it dosen't appear to be working.

The sheevaplug dosen't even see my Netgear WG111V2 (I'm 100% sure it is a RTL8187 device, I can also confirm it is working). The blue light dosen't even come on!

Also *lots* of problems at startup --

Code:
* Setting kernel variables (/etc/sysctl.d/10-process-security.conf)...        error: "vm.mmap_min_addr" is an unknown key
* Activiating swap
FATAL: Could not load /lib/modules/2.6.22.18/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.22.18/modules.dep: No such file or directory
* Starting early crpyto disks
FATAL: Could not load /lib/modules/2.6.22.18/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.22.18/modules.dep: No such file or directory

/lib/modules is *empty* on my system. Have I been shipped a faulty/corrupt sheevaplug?

Huh

ljones
19  General Category / General Discussion / Re: Setting up sheevaplug with wlan on: August 18, 2009, 02:35:31 PM
Smiley I might be in luck there as I have an old Netgear WG111v2 here which is RTL8187 based....I think! Though how do I apt-get if the sheeva isn't online yet? Can I just download it from somewhere online (not sure where) and copy it across via (say) a USB memory stick? Smiley Sorry I have no idea how ubuntu (is that what the sheeva uses?) manages its packages; normally my default linux is slackware where I can just use  e.g. installpkg as root.

Unfortunatly I don't have enough physical space free to put the sheevaplug next to the wireless router, let alone an external hard drive! Ack, the curse of small rooms, power supplies and computer cables(!). I have more space in a different room but then there's no phone line in that room for the router. Always the way  Roll Eyes

ljones
20  General Category / General Discussion / Setting up sheevaplug with wlan on: August 18, 2009, 01:01:47 PM
Hello all Smiley

I've finally (actually only yesterday) gotten my sheevaplug. To start off with I'd like to just to try something simple -- my idea is to use it as a basic FTP server. Snag is though that my  network isn't wired, I usually use a wireless network. I've not really done much to the sheevaplug except to just try to login (which worked ok). I did see the instructions here - http://www.openplug.org/plugwiki/index.php/New_Plugger_How_To - but some of those instructions apply to a wired network as opposed to a wireless one. How do I set up the wireless side?

Thanks

ljones
Pages: 1 [2]