• Home
  • Help
  • Search
  • Login
  • Register
  Show Posts
Pages: [1]
1  Hardware and U-Boot firmware / Hardware / Re: Dreamplug: WiFi AP problems on: January 08, 2012, 12:40:04 PM

Thanks! Tried that one, still does not work Sad

I've now checked that the uap8xxx.ko and the firmware files are identical in both installations, still the result is the same. Ubuntu works, Debian does not using the same kernel. What other factors could there be?
2  Hardware and U-Boot firmware / Hardware / Re: Dreamplug: WiFi AP problems on: January 07, 2012, 12:19:24 PM
Monologue continues Smiley

after boot, dmesg contains:

uap_probe: vendor=0x02DF device=0x9104 class=0 function=1
sbi_interrupt: sbi_interrupt(df960800) card or priv is NULL, card=de440000
UAP FW is active

Any new info there?
3  Hardware and U-Boot firmware / Hardware / Re: Dreamplug: WiFi AP problems on: January 07, 2012, 12:02:39 PM
Ok, further updates:

The kernel itself works fine, I'm able to use the self-compiled kernel with the Ubuntu rootfs so there must be something missing from the debian system. What could be missing? The only thing I can think of is the firmware. Need to double check.
4  Hardware and U-Boot firmware / Hardware / Re: Dreamplug: WiFi AP problems on: January 07, 2012, 08:48:43 AM
OK, I must be doing something wrong when building the kernel or with the debian rootfs.

I downloaded the dream-3.0.9-uImage from http://sheeva.with-linux.com/sheeva/3/3.0/3.0.9/ and it works with the stock ubuntu rootfs. I cannot boot my rootfs with that kernel image because it doesn't have sata support built in and my uboot doesn't support HD (for loading the kernel), that's why I have build my own kernel in the first place. As said in the first post, I have copied the firmware files from the ubuntu rootfs to the debian one.

What I did to compile the kernel:
  * Download kernel sources and patches from http://sheeva.with-linux.com/sheeva/3/3.0/3.0.9/source/
  * Applied all the patches
  * Copied dream-3.0.9.config to the kernel build directory as .config
  * change line SATA_MV=m to SATA_MV=y
  * cross-compile kernel and modules

5  Hardware and U-Boot firmware / Hardware / Re: Dreamplug: WiFi AP problems on: January 07, 2012, 05:33:25 AM
root@dreamplug:~# cat /sys/devices/platform/mvsdio/mmc_host/mmc0/mmc0\:0001/mmc0\:0001\:1/device
0x9104
root@dreamplug:~#
6  Hardware and U-Boot firmware / Hardware / Dreamplug: WiFi AP problems on: January 06, 2012, 11:55:52 AM
Hello!

I have a Dreamplug (serial 1113-*). I'm running Debian Wheezy with 3.0.9 kernel. The wireless AP isn't working. Symptoms are that when executing

uaputl sys_cfg_ssid <ssid>
uaputl sys_cfg_radio_ctl 0
uaputl bss_start

to bring up the AP the WiFi light blinks briefly and dmesg says:

ADDRCONF(NETDEV_UP): uap0: link is not ready
HOST_CMD_APCMD_POWER_MODE fail=2
7  General Category / Success stories / Re: Managing a USB hard drive on the Plug on: May 29, 2010, 11:14:49 AM

I have a Debian Squeeze setup where the root is on the internal NAND and /usr and /var are on an external USB hard drive. I'm using the latest kernel, 2.6.34.
I have the same problem, I can't mount the drives because the USB disk might not by ready when init gets to mountall.sh. Using rootwait kernel parameter doesn't work either, for some reason the kernel barfs because it cannot mount the ubifs root if the rootwait parameter is enabled.

So far I've solved this by adding a 10s delay to udev init script just before a successful exit.
Pages: [1]