• Home
  • Help
  • Search
  • Login
  • Register
  Show Posts
Pages: [1] 2
1  Linux Stuff / Kernel / Re: sheeva/dream 3.2.5 new kernel available on: February 15, 2012, 01:12:20 AM
i try again and it works, now i have 3.2.6 kernel, THANK YOU.
2  Linux Stuff / Kernel / Re: sheeva/dream 3.2.5 new kernel available on: February 14, 2012, 04:23:12 PM
ok thanks now it works but now i have a md5 error:
+ Md5Compare sheeva-3.2.6-Modules.tar.gz sheeva-3.2.6-Modules.tar.gz.md5
++ cut '-d ' -f1
++ cat sheeva-3.2.6-Modules.tar.gz.md5
++ cut '-d ' -f1
++ md5sum sheeva-3.2.6-Modules.tar.gz
+ [[ b6d1c3d28fafc41d0c11dc04b8ad67ca != de0c18f3aa00791dacf5c7592a6ddf6d ]]
+ echo 'Bad md5 detected on sheeva-3.2.6-Modules.tar.gz'
Bad md5 detected on sheeva-3.2.6-Modules.tar.gz
+ exit 1

maybe it's wrong on the server the md5 code, now i'm trying to install the new version 3.2.6

edit: it works perfect with 3.2.5
3  Linux Stuff / Kernel / Re: sheeva/dream 3.2.5 new kernel available on: February 14, 2012, 03:36:24 PM
root@debian:~# bash -x ./README-PLUG-UPDATE.sh 3.2.6 --nandkernel
+ set -e
+ set -u
+ ProgName=./README-PLUG-UPDATE.sh
+ KVer=
+ ERROR=0
++ which flash_eraseall
+ FLASH_ERASEALL=

this i get
4  Linux Stuff / Kernel / Re: sheeva/dream 3.2.5 new kernel available on: February 14, 2012, 08:03:21 AM
Hi, i'm trying to install this kernel but i can't i have downloaded the README file but when i introduce the command to start the update sudo ./README-PLUG-UPDATE.sh 3.2.5 --nandkernel
nothing happens just the prompt again and also no errors just nothing.
what am i doing wrong?
5  Linux Stuff / Linux distributions / Re: Can't Install debian on: March 20, 2011, 03:37:08 PM
Hi, thanks for the reply but finally i found the problem, the sd card was broken i have try with a new one an now it works ok.
6  Linux Stuff / Linux distributions / Can't Install debian on: March 20, 2011, 11:34:05 AM
Hi, i had debian install on my esata sheeva, but shudenly it didn't work, then i try to reinstall debian again but now i'm not able to start the installer because it always says that don't find the uImage, i'm trying to install it on a mmc, the same that i instaled it before, and of corse the files are on the sd and sd is formated on ext2, i have also try with ext3.
Marvell>> mmcinit
SDHC found. Card desciption is:
Manufacturer:       0x02, OEM "TM"
Product name:       "SD04G", revision 6.1
Serial number:      3201884208
Manufacturing date: 7/2010
CRC:                0x00, b0 = 0
Marvell>>  fatload mmc 0:1 0x00800000 /uImage
reading /uImage

** Unable to read "/uImage" from mmc 0:1 **

Marvell>> printenv
baudrate=115200
loads_echo=0
ipaddr=10.4.50.165
serverip=10.4.50.5
rootpath=/mnt/ARM_FS/
netmask=255.255.255.0
console=console=ttyS0,115200 mtdparts=nand_mtd:0xc0000@0(uboot)ro,0x1ff00000@0x100000(root)
CASset=min
MALLOC_len=1
ethprime=egiga0
bootargs_end=:::DB88FXX81:eth0:none
image_name=uImage
standalone=fsload 0x2000000 $(image_name);setenv bootargs $(console) root=/dev/mtdblock0 rw ip=$(ipaddr):$(serverip)$(bootargs_end) $(mvPhoneConfig); bootm 0x2000000;
ethaddr=00:50:43:06:01:06
ethmtu=1500
mvPhoneConfig=mv_phone_config=dev0:fxs,dev1:fxs
mvNetConfig=mv_net_config=(00:11:88:0f:62:81,0:1:2:3),mtu=1500
usb0Mode=host
yuk_ethaddr=00:00:00:EE:51:81
nandEcc=1bit
netretry=no
rcvrip=169.254.100.100
loadaddr=0x02000000
autoload=no
ethact=egiga0
bootargs_console=console=ttyS0,115200
bootargs_root=root=/dev/mmcblk0p2
bootcmd=setenv bootargs $(bootargs_console) $(bootargs_root); run bootcmd_mmc; bootm 0x00800000 0x01100000
bootargs=console=ttyS0,115200 root=/dev/mmcblk0p2
filesize=445C6F
bootcmd_mmc=mmcinit; ext2load mmc 0:1 0x01100000 /uInitrd; ext2load mmc 0:1 0x00800000 /sheeva-2.6.33.3-uImage
arcNumber=2678
stdin=serial
stdout=serial
stderr=serial
mainlineLinux=yes
enaMonExt=no
enaCpuStream=no
enaWrAllo=no
pexMode=RC
disL2Cache=no
setL2CacheWT=yes
disL2Prefetch=yes
enaICPref=yes
enaDCPref=yes
sata_dma_mode=yes
netbsd_en=no
vxworks_en=no
bootdelay=3
disaMvPnp=no
enaAutoRecovery=yes

Environment size: 1401/131068 bytes

reading /uImage

** Unable to read "/uImage" from mmc 0:1 **

7  Linux Stuff / General Linux questions / Problem with printer on: October 27, 2010, 05:26:03 AM
Hi, i have debian on hseeva and i have recently install printconf to add a printer, the HP Deskjet 840c, the printer is now installed and print ok form the sheeva but i'm trying to print over the network by sharing it and i can't, the print is share and my windows 7 PC detect it and install ok but if i send anything to print the print does nothing and on the qeue of the print don't appear nothing, but can i do. Thanks
8  Linux Stuff / General Linux questions / Re: Sheeva don't found swap on: October 27, 2010, 05:23:33 AM
thanks alot but finally the las version of gparted detect my sd card and i could do the partitions.
9  Linux Stuff / General Linux questions / Re: Sheeva don't found swap on: October 26, 2010, 12:05:04 PM
thanks i knows gparted and is the first program that i try to use but the problem i that it don't recognized my card reader and i cannot do the partitions then i made it with fdisk, any idea to force the detection on gparted, also i'm going to download a newer version of gparted because i think that mine could be obsolet
10  Linux Stuff / General Linux questions / Re: Sheeva don't found swap on: October 26, 2010, 05:34:38 AM
ok thanks i forget to do the mkswap now it works ok, but i have another problem is that the system partion has 3GB aprox, but the system only recognized 1GB:
debian:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mmcblk0p2         1004052    642300    310748  68% /
tmpfs                   257000         0    257000   0% /lib/init/rw
udev                     10240       668      9572   7% /dev
tmpfs                   257000         0    257000   0% /dev/shm
/dev/sda1            856996672 699111956 114351784  86% /media/sata
/dev/sda3            103762968  39605676  58886368  41% /media/grabaciones
/dev/mmcblk0p1          497829     19334    452793   5% /boot

and fdisk show:

debian:~# fdisk /dev/mmcblk0

Command (m for help): p

Disk /dev/mmcblk0: 3963 MB, 3963617280 bytes
255 heads, 63 sectors/track, 481 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000e63d8

        Device Boot      Start         End      Blocks   Id  System
/dev/mmcblk0p1   *           1          64      514048+  83  Linux
/dev/mmcblk0p2              65         415     2819407+  83  Linux
/dev/mmcblk0p3             416         481      530145   82  Linux swap / Solaris


what can ido to expand the root partion?
11  Linux Stuff / General Linux questions / Sheeva don't found swap on: October 26, 2010, 02:38:33 AM
Hi, i have move my debian system to another sd card with more capacity, i have partition the new sd card and copy the system install y my old card, all work well but debian(my so on sheeva) don't recognized the swap partition, here is the start up:
Quote
usbcore: registered new interface driver usbhid
usbhid: USB HID core driver
oprofile: using timer interrupt.
TCP cubic registered
NET: Registered protocol family 17
lib80211: common routines for IEEE802.11 drivers
rtc-mv rtc-mv: setting system clock to 2010-10-26 09:35:21 UTC (1288085721)
Freeing init memory: 132K
Loading, please wait...
WARNING: Couldn't open directory /lib/modules/2.6.33.3: No such file or directory
FATAL: Could not open /lib/modules/2.6.33.3/modules.dep.temp for writing: No such file or directory
Begin: Loading essential drivers ... FATAL: Could not load /lib/modules/2.6.33.3/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.33.3/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.33.3/modules.dep: No such file or directory
FATAL: Could not load /lib/modules/2.6.33.3/modules.dep: No such file or directory
done.
Begin: Running /scripts/init-premount ... FATAL: Could not load /lib/modules/2.6.33.3/modules.dep: No such file or directory
done.
Begin: Mounting root file system ... Begin: Running /scripts/local-top ... Begin: Loadingmodprobe: FATAL: Could not load /lib/modules/2.6.33.3/modules.dep: No such file or directory

Failure: failed to load module linear.
modprobe: FATAL: Could not load /lib/modules/2.6.33.3/modules.dep: No such file or directory

Failure: failed to load module multipath.
modprobe: FATAL: Could not load /lib/modules/2.6.33.3/modules.dep: No such file or directory

Failure: failed to load module raid0.
modprobe: FATAL: Could not load /lib/modules/2.6.33.3/modules.dep: No such file or directory

Failure: failed to load module raid1.
modprobe: FATAL: Could not load /lib/modules/2.6.33.3/modules.dep: No such file or directory

Failure: failed to load module raid456.
modprobe: FATAL: Could not load /lib/modules/2.6.33.3/modules.dep: No such file or directory

Failure: failed to load module raid5.
modprobe: FATAL: Could not load /lib/modules/2.6.33.3/modules.dep: No such file or directory

Failure: failed to load module raid6.
modprobe: FATAL: Could not load /lib/modules/2.6.33.3/modules.dep: No such file or directory

Failure: failed to load module raid10.
done.
FATAL: Could not load /lib/modules/2.6.33.3/modules.dep: No such file or directory
done.
Begin: Running /scripts/local-premount ... done.
FATAL: Could not load /lib/modules/2.6.33.3/modules.dep: No such file or directory
Begin: Running /scripts/local-bottom ... done.
done.
Begin: Running /scripts/init-bottom ... done.
INIT: version 2.86 booting
Starting the hotplug events dispatcher: udevdudevd version 125 started
.
Synthesizing the initial hotplug events...done.
Waiting for /dev to be fully populated...sata_mv sata_mv.0: version 1.28
sata_mv sata_mv.0: slots 32 ports 2
scsi0 : sata_mv
scsi1 : sata_mv
ata1: SATA max UDMA/133 irq 21
ata2: SATA max UDMA/133 irq 21
ata1: SATA link down (SStatus 0 SControl F300)
ata2: SATA link up 3.0 Gbps (SStatus 123 SControl F300)
ata2.00: ATA-8: ST31000340AS, SD15, max UDMA/133
ata2.00: 1953525168 sectors, multi 0: LBA48 NCQ (depth 31/32)
ata2.00: configured for UDMA/133
scsi 1:0:0:0: Direct-Access     ATA      ST31000340AS     SD15 PQ: 0 ANSI: 5
sd 1:0:0:0: [sda] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
sd 1:0:0:0: Attached scsi generic sg0 type 0
sd 1:0:0:0: [sda] Write Protect is off
sd 1:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
 sda: sda1 sda2 sda3
sd 1:0:0:0: [sda] Attached SCSI disk
done.
Setting the system clock.
Activating swap...Unable to find swap-space signature
failed.
Checking root file system...fsck 1.41.3 (12-Oct-2008)
e2fsck 1.41.3 (12-Oct-2008)
/dev/mmcblk0p2: clean, 25517/63872 files, 164564/255031 blocks
done.
Setting the system clock.
Cleaning up ifupdown....
Loading kernel modules...done.
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock1, sector 0
Buffer I/O error on device mtdblock1, logical block 0
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock1, sector 8
Buffer I/O error on device mtdblock1, logical block 1
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock1, sector 16
Buffer I/O error on device mtdblock1, logical block 2
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock1, sector 24
Buffer I/O error on device mtdblock1, logical block 3
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock1, sector 0
Buffer I/O error on device mtdblock1, logical block 0
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 1920
Buffer I/O error on device mtdblock0, logical block 240
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 1920
Buffer I/O error on device mtdblock0, logical block 240
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 2032
Buffer I/O error on device mtdblock0, logical block 254
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 2040
Buffer I/O error on device mtdblock0, logical block 255
uncorrectable error :
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 2032
Buffer I/O error on device mtdblock0, logical block 254
Assembling MD arrays...done (no arrays found in config file or automatically).
Checking file systems...fsck 1.41.3 (12-Oct-2008)
e2fsck 1.41.3 (12-Oct-2008)
/dev/sda1: recovering journal
/dev/sda1: clean, 25728/54419456 files, 178193498/217664677 blocks
e2fsck 1.41.3 (12-Oct-2008)
Superblock last write time is in the future.  Fix? yes

/dev/mmcblk0p1 was not cleanly unmounted, check forced.
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information

/dev/mmcblk0p1: ***** FILE SYSTEM WAS MODIFIED *****
/dev/mmcblk0p1: 21/128520 files (14.3% non-contiguous), 35553/514048 blocks
fsck died with exit status 1
done.
Setting kernel variables (/etc/sysctl.conf)...done.
Mounting local filesystems...kjournald starting.  Commit interval 5 seconds
EXT3-fs (sda1): using internal journal
EXT3-fs (sda1): mounted filesystem with writeback data mode
EXT3-fs (sda3): warning: checktime reached, running e2fsck is recommended
kjournald starting.  Commit interval 5 seconds
EXT3-fs (sda3): using internal journal
EXT3-fs (sda3): recovery complete
EXT3-fs (sda3): mounted filesystem with writeback data mode
done.
Activating swapfile swap...Unable to find swap-space signature
done.
Setting up networking....
Configuring network interfaces...done.
Starting portmap daemon....
Starting NFS common utilities: statdNET: Registered protocol family 10
ADDRCONF(NETDEV_UP): eth0: link is not ready
Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
 idmapdeth0: link up, 1000 Mb/s, full duplex, flow control disabled
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
.
Setting console screen modes and fonts.
INIT: Entering runlevel: 2
Starting enhanced syslogd: rsyslogd.
Starting OpenBSD Secure Shell server: sshd.
Starting MTA: exim4.
Starting NFS common utilities: statd idmapd.
Exporting directories for NFS kernel daemon...exportfs: /etc/exports [1]: Neither 'subtree_check' or 'no_subtree_check' specified for export "192.168.1.12:/media/sata/share/torrents".
  Assuming default behaviour ('no_subtree_check').
  NOTE: this default has changed since nfs-utils version 1.0.x

exportfs: /etc/exports [2]: Neither 'subtree_check' or 'no_subtree_check' specified for export "192.168.1.25:/media/grabaciones".
  Assuming default behaviour ('no_subtree_check').
  NOTE: this default has changed since nfs-utils version 1.0.x

exportfs: /etc/exports [3]: Neither 'subtree_check' or 'no_subtree_check' specified for export "192.168.1.9:/media/grabaciones".
  Assuming default behaviour ('no_subtree_check').
  NOTE: this default has changed since nfs-utils version 1.0.x

.
Starting NFS kernel daemon: nfsdsvc: failed to register lockdv1 RPC service (errno 97).
NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
NFSD: starting 90-second grace period
 mountd.
Not starting internet superserver: no services enabled.
Starting Samba daemons: nmbd smbd.
Starting MD monitoring service: mdadm --monitor.
Starting ftp server: proftpdwarning: `proftpd' uses 32-bit capabilities (legacy support in use)
.
Starting deferred execution scheduler: atd.
Starting periodic command scheduler: crond.
Starting MLDonkey: mlnet configuration file prevent mlnet to be started (use force-start).

Debian GNU/Linux 5.0 debian ttyS0

debian login:
12  Hardware and U-Boot firmware / U-Boot stuff / Re: Help on: May 19, 2010, 02:12:14 PM
if i reset an interupt the boot, then type boot and also debian starts.
13  Hardware and U-Boot firmware / U-Boot stuff / Re: Help on: May 19, 2010, 01:51:43 PM
if i do the steps that you say debian boots from mi sd card, i really don't understand what it's the problem
14  Hardware and U-Boot firmware / U-Boot stuff / Re: Help on: May 19, 2010, 11:51:12 AM
why did you say that it not consistent?, y can have troubles with this?, now and i out of home when i arrive home try these commands. Thanks
15  Hardware and U-Boot firmware / U-Boot stuff / Re: Help on: May 19, 2010, 02:31:06 AM
USB 0: host mode
PEX 0: interface detected no Link.
Net:   egiga0 [PRIME], egiga1
Hit any key to stop autoboot:  0
Marvell>>
Marvell>> printenv
baudrate=115200
loads_echo=0
ipaddr=10.4.50.165
serverip=10.4.50.5
rootpath=/mnt/ARM_FS/
netmask=255.255.255.0
console=console=ttyS0,115200 mtdparts=nand_mtd:0xc0000@0(uboot)ro,0x1ff00000@0x100000(root)
CASset=min
MALLOC_len=1
ethprime=egiga0
bootargs_end=:::DB88FXX81:eth0:none
image_name=uImage
standalone=fsload 0x2000000 $(image_name);setenv bootargs $(console) root=/dev/mtdblock0 rw ip=$(ipaddr):$(serverip)$(bootargs_end) $(mvPhoneConfig); bootm 0x2000000;
ethaddr=00:50:43:06:01:06
ethmtu=1500
mvPhoneConfig=mv_phone_config=dev0:fxs,dev1:fxs
mvNetConfig=mv_net_config=(00:11:88:0f:62:81,0:1:2:3),mtu=1500
usb0Mode=host
yuk_ethaddr=00:00:00:EE:51:81
nandEcc=1bit
netretry=no
rcvrip=169.254.100.100
loadaddr=0x02000000
autoload=no
arcNumber=2097
ethact=egiga0
bootargs=console=ttyS0,115200 mtdparts=nand_mtd:0xc0000@0(uboot)ro,0x1ff00000@0x100000(root) root=/dev/nfs rw nfsroot=10.4.50.5:/mnt/ARM_FS/ ip=10.4.50.165:10.4.50.5:::DB88FXX81:eth0:none mv_net_config=(00:11:88:0f:62:81,0:1:2:3),mtu=1500 mv_phone_config=dev0:fxs,dev1:fxs
bootargs_console=console=ttyS0,115200
bootargs_root=root=/dev/mmcblk0p2
bootcmd_mmc=mmcinit; ext2load mmc 0:1 0x01100000 /uInitrd; ext2load mmc 0:1 0x00800000 /uImage
bootcmd=setenv bootargs $(bootargs_console) $(bootargs_root); run bootcmd_mmc; bootm 0x00800000 0x01100000
stdin=serial
stdout=serial
stderr=serial
mainlineLinux=yes
enaMonExt=no
enaCpuStream=no
enaWrAllo=no
pexMode=RC
disL2Cache=no
setL2CacheWT=yes
disL2Prefetch=yes
enaICPref=yes
enaDCPref=yes
sata_dma_mode=yes
netbsd_en=no
vxworks_en=no
bootdelay=3
disaMvPnp=no
enaAutoRecovery=yes

Environment size: 1592/131068 bytes
Marvell>>

here are the printenv i must say that i have try to install debian on a mmc
Pages: [1] 2