• Home
  • Help
  • Search
  • Login
  • Register
  Show Posts
Pages: [1] 2 3 ... 5
1  Hardware and U-Boot firmware / Hardware / Re: Bluetooth dongle on: September 09, 2009, 01:51:25 PM
q> How did you bind your device?

I used
hcitool auth XXXXXXXXXX
2  Hardware and U-Boot firmware / Hardware / Re: Bluetooth dongle on: July 20, 2009, 09:30:25 AM
I've tried 2.6.30/ and 2.6.31 with on luck.
I've installed bluez-tool 2.30 and 2.45.
I am able to scan bluetooth devices in my neighborhood but
I can connect my device (hcitool cc XXXXXXXXX) only for a few seconds.
Authentication (hcitool auth XXXXXXXXXX) doesn't work.

How did you bind your device?

 
3  General Category / Application ideas and development Q/A / Re: Bluetooth dongle on: July 09, 2009, 03:15:18 PM
can you advice how can I install bluetooth as module?
4  Hardware and U-Boot firmware / Hardware / Re: Bluetooth dongle on: July 09, 2009, 03:13:26 PM
does anyone has a kernel with a bluetooth support
or
knows how to add bluetooth to the plug

I've installed v2.30 but it doesn't work there also
5  Hardware and U-Boot firmware / U-Boot stuff / Re: Dead Plug on: July 09, 2009, 02:20:50 PM
Thanks Morgan
doesn't work
6  Hardware and U-Boot firmware / U-Boot stuff / Re: alpha-6 installer on: July 09, 2009, 02:19:44 PM
Here are my steps:

Step #1:
Downloaded alpha-6 installer and setup it.

Step #2:
Formate USB stick in FAT32 on my Windiws XP machine and wrote all files from from directory "installer"  (alpha-6 installer) to the USB stick.

Step #3:
moved USB stick from Windows computer to ShevaPlug.

Step #4:
I run ./runme.sh from my Ubuntu computer.
Eveything looked alright.

Code:
root@stockalerts:/tmp/installer/sheevaplug-installer-alpha-6# ./runme.sh
 ****   Preparing environment variables file ...
 ****   Burning uboot and environment variables ... This will take few minutes ...
Open On-Chip Debugger 0.2.0-in-development (2009-05-17-10:32) svn:1800M


BUGS? Read http://svn.berlios.de/svnroot/repos/openocd/trunk/BUGS


$URL: http://svn.berlios.de/svnroot/repos/openocd/trunk/src/openocd.c $
3000 kHz
dcc downloads are enabled
Info : JTAG tap: feroceon.cpu tap/device found: 0x20a023d3 (Manufacturer: 0x1e9, Part: 0x0a02, Version: 0x2)
Info : JTAG Tap/device matched
Error: unknown EmbeddedICE version (comms ctrl: 0x00000018)
Warn : no telnet port specified, using default port 4444
Warn : no gdb port specified, using default port 3333
Warn : no tcl port specified, using default port 6666
target state: halted
target halted in ARM state due to debug-request, current mode: Supervisor
cpsr: 0x000000d3 pc: 0xffff0000
MMU: disabled, D-Cache: disabled, I-Cache: disabled
0 0 1 0: 00052078
NAND flash device 'NAND 512MiB 3,3V 8-bit' found
successfully erased blocks 5 to 6 on NAND flash device 'NAND 512MiB 3,3V 8-bit'
wrote file uboot-env.bin to NAND flash 0 up to offset 0x000c0000 in 17.885023s
target state: halted
target halted in ARM state due to debug-request, current mode: Supervisor
cpsr: 0x000000d3 pc: 0xffff0000
MMU: disabled, D-Cache: disabled, I-Cache: disabled
0 0 1 0: 00052078
NAND flash device 'NAND 512MiB 3,3V 8-bit' found
successfully erased blocks 0 to 4 on NAND flash device 'NAND 512MiB 3,3V 8-bit'
wrote file uboot.bin to NAND flash 0 up to offset 0x00073000 in 64.155563s
 ****   U-boot should be up and running now. Open your console ...
root@stockalerts:/tmp/installer/sheevaplug-installer-alpha-6#


Step 5#
Waited 10 min.

Step 6#
Opened terminal and it worked

What I did?
I just used another memory stick.


Thank you everyone.


7  Hardware and U-Boot firmware / U-Boot stuff / alpha-6 installer on: July 09, 2009, 10:39:32 AM
I was trying to update my plug using alpha-6 installer.
everything works alright until it boots from a USB stick or SD card.

any advice?

Code:
USB 0: host mode
PEX 0: interface detected no Link.
Net:   egiga0 [PRIME], egiga1
Hit any key to stop autoboot:  0

NAND read: device 0 offset 0x100000, size 0x400000

Reading data from 0x4ff800 -- 100% complete.
 4194304 bytes read: OK
## Booting image at 00800000 ...
Bad Magic Number
8  General Category / General Discussion / Re: Sheevaplug installer - alpha-6 release - Testers needed on: July 09, 2009, 08:57:33 AM
Does anyone knows how to fix Bad Magic Number
Installer worked good but booting gave me some errors.

Code:
512 MB

CPU : Marvell Feroceon (Rev 1)

Streaming disabled
Write allocate disabled


USB 0: host mode
PEX 0: interface detected no Link.
Net:   egiga0 [PRIME], egiga1
Hit any key to stop autoboot:  0

NAND read: device 0 offset 0x100000, size 0x400000

Reading data from 0x4ff800 -- 100% complete.
 4194304 bytes read: OK
## Booting image at 00800000 ...
Bad Magic Number
9  Hardware and U-Boot firmware / U-Boot stuff / Re: Dead Plug on: July 09, 2009, 08:32:51 AM
only green  LED is on.
I don't know its ip address to connect it by SSH.
Any advice?
10  Hardware and U-Boot firmware / U-Boot stuff / Re: Dead Plug on: July 07, 2009, 03:39:29 PM
It worked but now it doesn't. Everything looks alright.  Connection is solid. Terminal works with everything except Sheva Plug.
Any ideas?
11  Hardware and U-Boot firmware / U-Boot stuff / Dead Plug on: July 07, 2009, 02:31:20 PM
My plug doesn't dive me any message to the terminal. Is any way to reset it?
12  General Category / General Discussion / Re: Sheevaplug installer - alpha-6 release - Testers needed on: July 06, 2009, 03:57:12 PM
it doesn't work for me.
Any help would be appreciated.

<code>root@stockalerts:/tmp/installer/sheevaplug-installer-alpha-6# sudo ./runme.sh
 ****   Preparing environment variables file ...
 ****   Burning uboot and environment variables ... This will take few minutes ...
Open On-Chip Debugger 0.2.0-in-development (2009-05-17-10:32) svn:1800M


BUGS? Read http://svn.berlios.de/svnroot/repos/openocd/trunk/BUGS


$URL: http://svn.berlios.de/svnroot/repos/openocd/trunk/src/openocd.c $
3000 kHz
dcc downloads are enabled
Info : JTAG tap: feroceon.cpu tap/device found: 0x20a023d3 (Manufacturer: 0x1e9, Part: 0x0a02, Version: 0x2)
Info : JTAG Tap/device matched
Error: unknown EmbeddedICE version (comms ctrl: 0x00000018)
Warn : no telnet port specified, using default port 4444
Warn : no gdb port specified, using default port 3333
Warn : no tcl port specified, using default port 6666
target state: halted
target halted in ARM state due to debug-request, current mode: Supervisor
cpsr: 0x000000d3 pc: 0xffff0000
MMU: disabled, D-Cache: disabled, I-Cache: disabled
0 0 1 0: 00052078
NAND flash device 'NAND 512MiB 3,3V 8-bit' found
successfully erased blocks 5 to 6 on NAND flash device 'NAND 512MiB 3,3V 8-bit'
wrote file uboot-env.bin to NAND flash 0 up to offset 0x000c0000 in 17.862015s
target state: halted
target halted in ARM state due to debug-request, current mode: Supervisor
cpsr: 0x000000d3 pc: 0xffff0000
MMU: disabled, D-Cache: disabled, I-Cache: disabled
0 0 1 0: 00052078
NAND flash device 'NAND 512MiB 3,3V 8-bit' found
Warn : invalid block: 2
Error: erase operation didn't pass, status: 0xe1
erase failed
Error: timed out while waiting for target halted
Error: error executing hosted NAND write
Warn : target not halted
Warn : target reentered debug state, but not at the desired exit point: 0x7fffff0
Error: error executing hosted NAND write
Error: invalid mode value encountered
Error: cpsr contains invalid mode value - communication failure
Error: error executing hosted NAND write
Warn : target not halted
Warn : target was in unknown state when halt was requested
Warn : DBGACK set while target was in unknown state. Reset or initialize target.
target state: halted
target halted in ARM state due to debug-request, current mode: Supervisor
cpsr: 0x600000d3 pc: 0x1000005c
MMU: disabled, D-Cache: disabled, I-Cache: disabled
Error: invalid mode value encountered
Error: cpsr contains invalid mode value - communication failure
Error: error executing hosted NAND write
Warn : target not halted
Warn : target was in unknown state when halt was requested
Warn : DBGACK set while target was in unknown state. Reset or initialize target.
target state: halted
target halted in ARM state due to debug-request, current mode: Supervisor
cpsr: 0x600000d3 pc: 0x1000005c
MMU: disabled, D-Cache: disabled, I-Cache: disabled
Warn : target reentered debug state, but not at the desired exit point: 0x0010
Error: error executing hosted NAND write
Warn : target reentered debug state, but not at the desired exit point: 0x10000014
Error: error executing hosted NAND write
Error: timed out while waiting for target halted
Error: error executing hosted NAND write
Warn : target not halted
Error: timed out while waiting for target halted
Error: error executing hosted NAND write
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Warn : target not halted
Error: invalid mode value encountered
Error: cpsr contains invalid mode value - communication failure
Error: error executing hosted NAND write
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Error: NAND flash access requires halted target
Warn : target not halted
Warn : target was in unknown state when halt was requested
Warn : DBGACK set while target was in unknown state. Reset or initialize target.
target state: halted
target halted in ARM state due to debug-request, current mode: Supervisor
cpsr: 0x600000d3 pc: 0x1000005c
MMU: disabled, D-Cache: disabled, I-Cache: disabled
wrote file uboot.bin to NAND flash 0 up to offset 0x00073000 in 66.784401s
 ****   U-boot should be up and running now. Open your console ...
root@stockalerts:/tmp/installer/sheevaplug-installer-alpha-6#</code>
13  Hardware and U-Boot firmware / U-Boot stuff / Re: end_request: I/O error, dev mtdblock0, sector 0 on: May 15, 2009, 10:21:10 AM
root@stockalerts:/dev# modprobe usbserial
FATAL: Module usbserial not found.
root@stockalerts:/dev# modprobe ftdi_sio vendor=0x9e88 product=0x9e8f
root@stockalerts:/dev#
root@stockalerts:/dev# ls ttyU*
ttyUSB0  ttyUSB1
root@stockalerts:/dev#
14  Hardware and U-Boot firmware / U-Boot stuff / Re: end_request: I/O error, dev mtdblock0, sector 0 on: May 15, 2009, 10:03:17 AM
it works with /ttyUSB0 but when I try
sudo openocd -f /usr/local/lib/openocd/board/sheevaplug.cfg
it close the terminal

Look at the output below


root@stockalerts:/dev# picocom -b 115200 /dev/ttyUSB0
picocom v1.4

port is        : /dev/ttyUSB0
flowcontrol    : none
baudrate is    : 115200
parity is      : none
databits are   : 8
escape is      : C-a
noinit is      : no
noreset is     : no
nolock is      : no
send_cmd is    : ascii_xfr -s -v -l10
receive_cmd is : rz -vv

Terminal ready

FATAL: term closed
root@stockalerts:/dev#
15  Hardware and U-Boot firmware / U-Boot stuff / Re: end_request: I/O error, dev mtdblock0, sector 0 on: May 15, 2009, 09:46:29 AM
root@stockalerts:~# modprobe usbserial
FATAL: Module usbserial not found.
root@stockalerts:~# picocom -b 115200 /dev/ttyUSB1
picocom v1.4

port is        : /dev/ttyUSB1
flowcontrol    : none
baudrate is    : 115200
parity is      : none
databits are   : 8
escape is      : C-a
noinit is      : no
noreset is     : no
nolock is      : no
send_cmd is    : ascii_xfr -s -v -l10
receive_cmd is : rz -vv


FATAL: cannot open /dev/ttyUSB1: No such file or directory
root@stockalerts:~#
Pages: [1] 2 3 ... 5